Stuck on load screen after flashing

imarx

Active member
May 7, 2010
25
0
0
Visit site
I rooted my AT&T One X and installed TWRP without issues, but now whenever I try to flash a ROM and reboot it gets stuck on the ROM loading screen. I have tried both CM10 and AOKP using both TWRP and GooManager but get the same problem every time. Does anyone have any suggestions for what to do?
 

cbatiste1993

Well-known member
Jul 14, 2011
100
4
0
Visit site
Did you flash the boot.img through fastboot before flashing the ROM?

Sent from my HTC One XL running ViperXL 3.0.0 using Android Central Forums
 

imarx

Active member
May 7, 2010
25
0
0
Visit site
No, I got the impression that you didn't need to flash boot.img if you were using TWRP. Do you do that before flashing the ROM? If so, how do you get back into recovery after flashing boot.img?
 

Bizzle69

Well-known member
May 4, 2012
681
4
0
Visit site
(Even though you may have done these steps, DO THEM AGAIN)

Do a factory reset, wipe system (this is important), reboot to bootloader>fastboot flash rom, flash it again in TWRP...

Needing to fastboot has nothing to do with what recovery you use, it's because you have hboot 1.14 is the need to fastboot flash then TWRP

EDIT: to get back to bootloader, hold power button and volume DOWN (not up).. As soon as the phone reboots, let go of power button, but keep holding down the volume DOWN button
 

prissysox

Trusted Member
Jun 11, 2010
1,246
12
0
Visit site
(Even though you may have done these steps, DO THEM AGAIN)

Do a factory reset, wipe system (this is important), reboot to bootloader>fastboot flash rom, flash it again in TWRP...

Needing to fastboot has nothing to do with what recovery you use, it's because you have hboot 1.14 is the need to fastboot flash then TWRP

EDIT: to get back to bootloader, hold power button and volume DOWN (not up).. As soon as the phone reboots, let go of power button, but keep holding down the volume DOWN button

Trying again. *Fingers crossed*:confused:


Still stuck on CyanogenMod spinning screen. Been there for over 20 minutes. How long should it take? How many tries?
 
Last edited:

imarx

Active member
May 7, 2010
25
0
0
Visit site
Thanks for the help. I actually ended up flashing CM10 and Gapps first through TWRP, and then flashed the boot.img through fast boot which worked perfectly.
 

Forum statistics

Threads
943,732
Messages
6,919,797
Members
3,159,191
Latest member
Shiny_2084