tethering problem


New member
Jun 2, 2011
Visit site
Hello all,
I am all of sudden having a tethering issue with my s2. I used to be able to tether my laptops and any other cell phone to my s2 as a wifi hotspot. I am rooted with the stock 2.34 rom. uckh7, kernal version 2.635.7 that has CWM. I have titanium backup pro installed and have always had the tethering mangager app frozen. Now I can only tether other cell phones using the hotspot from my s2. My ipad and laptops will show connected to my s2 network but will not connect to internet even after rebooting ipad and laptops.. I have tried configuring the hotspot app with and without security, tried various passwords with and without alpha numerical sequences, I have tried FoxFi, and the latest WiFi tether app, and all have same results. I have removed the tether manager completly using TB and still same. I also performed a restore from CWM and still the same. I have not performed a factory reset yet because I believe all that does is remove all user data, not change the system data. I don't want to bring it to an ATT service store because I don't want an exchange unit that will more than likely have the 2.36 rom. I am at a loss right now..
Any and all thoughts, advise, recommendations appreciated.