TWRP Driving me insane! Please Help! How can I fix it?

A

AC Question

TWRP Driving me insane! Please Help!

So i rooted and installed TWRP with cyanogen on my Galaxy Tab 3 7.0 sm-t210.

Cyanogen seems to be very buggy on the tablet it keeps freezing so i decided to set it back to stock. I am unable to flash back to stock with odin (ive tried 3 stock roms) and it keeps failing,

I figured since i have TWRP on the device ill just flash another rom on it. When i download a rom to the device and save it to the downloads folder it appears to have transferred correctly but once i boot into TWRP the file doesn't exist! To make matters even more strange in my downloads folder i have 3 files, one being the cyanogen zip. I've tried to delete this zip and in android it says its deleted fine but once i open TWRP the dam file is still there!

Additionally every time i reboot the tablet it seems to revert back to the exact way it was left a few days ago.. on boot it opens the browser on a specific website and deletes any files ive downloaded!
 

Forum statistics

Threads
943,839
Messages
6,920,272
Members
3,159,254
Latest member
roth4796