Unable to run nova launcher on android tv box

  • Thread starter Android Central Question
  • Start date
A

Android Central Question

Hi there I hope somebody can help me with the following:

I have an android tv box with an as usual boring home launcher. When I install and run Nova Launcher all seems ok and on first run it takes me through some basic setting screens, however once completed when I press the home button and select nova launcher as default it opens up for a few seconds and then reverts back to the standard launcher that came with the box.

The same happens with other launchers from the play store.

The box is a :T9 RK3328 Android 8.1 4GB/32GB
I have exactly the same problem with another box: MXR PRO TV Box Android 7.1 Cortex-A53 4GB+32GB Quad Core

I have seen a post that describes a similar issue however it doesn't seem to provide the solution for me.

Many thanks for your help :)
 

Kev Day

New member
Jan 20, 2019
1
0
0
Visit site
Hey

Yep, having the exact same problem as you guys. Getting annoying now. I've tried lots of other launchers too, but all with the same result.

Out of interest, what is showing as your default launcher that you're stuck with? Mine is Smart Launher (the spelling mistake is intentional and exactly as it shows up under apps!).

Fingers crossed some bright spark can assist!
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
Some implementations of Android don't allow a different launcher to run, and it's not like there are a lot of ROMs to choose from, so you can choose one that allows a different launcher. But what are you using the box for - TV or running Android? (If what you see most of the time is Kodi, who cares what the launcher is?)
 

Arik Iannone

New member
Feb 4, 2019
4
0
0
Visit site
I mentioned another post I believe it's a Oreo 8 one thing a lot of launchers aren't dragging or dropping to Evie launcher seems to work the best.. one work around a vuse when I can't install another launcher is to download SD Maid APK if you have root download the launcher you want to use before you open it go to your other launcher in SD Maid and freeze it and then open the new launcher sometimes works