Unable to use SD card in Galaxy Tab A

ISDPCMAN

New member
Sep 13, 2010
2
0
0
Visit site
I purchased a new Samsung Galaxy Tab A with S Pen (model SM-P580). It's fast and I'm mostly happy with it EXCEPT I cannot seem to get it to use the SD card! The machine recognizes that there's an SD card in there. It correctly sees the size (64 GB). But I cannot [reliably] access it. When I plug it into my Windows 10 PC (usb cable) I see that there's an SD card and the tablet storage. I cannot read ANYTHING from the SD card. I can read from local storage but I cannot create a folder in either local or SD card storage. From My Files (on the tablet) I can see the SD card but cannot create a folder. I can create a folder on the local storage side.

SOMETIMES, if I unmount and mount the SD card it will show up on the tablet and the PC but from the PC I still cannot copy files to it.

If I remove the SD card and plug it into my SD card reader on the PC it works fine.

I have formatted the card on the PC and formatted it on the tablet. It does not seem to make a difference, though.

I got with Samsung support (they're not very bright) and after 45 minutes online and having them remote into my tablet they FINALLY got it to work (had to reboot the tablet several times). But some apps were not working so they had me do a factory reset and that killed the fix for the SD card! I tried contacting their support, again, but they were worthless. They referred me to their specialty SD card department and all they did was issue me an RMA for the card. I have tried this with two different 64 GB cards and neither will work in the tablet. They work fine on the PC, though.

I'm certain this has something to do with the OS itself but I cannot figure out what the fix is. Does anyone have any ideas how to fix this? The tablet is running Android 6.0.1 (Marshmallow?). It has 16 GB of ram.
 
Last edited:

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,738
4,908
113
Visit site
The SD card could be corrupt, defective, or counterfeit. Install SD Insight to see if the card is genuine or counterfeit. Counterfeit cards are programmed to report more storage than they actually have, and if you try saving more than the card can actually hold, then files can start getting corrupt.


If it's a valid card, then go to Settings>Storage, Unmount the card, remove it, and insert it into your computer. Can the computer see the card? If so, run chkdsk to look for bad sectors: http://forums.androidcentral.com/am...guide-using-chkdsk-fix-corrupted-sd-card.html
 

jpintn

Active member
Mar 28, 2016
41
1
8
Visit site
Make sure the card is not locked. You will have to place into the adaptor to check. There is a small sliding tab on the edge of the adaptor.
 

Members online

Forum statistics

Threads
943,839
Messages
6,920,272
Members
3,159,254
Latest member
roth4796