USB Host Mode Not Working After Hard Reset/Repair by AT&T Tech


New member
Mar 18, 2014
Visit site
Hello, I'm new to the world of Android, but not new to computers. I got my Samsung Galaxy S3 in early December 2013 as replacement phone. It's my first smart phone. I started having problems with it one weekend in early March. I noticed I hadn't been getting text messages and tried to send some out and they wouldn't go. Plus, updates from Google Play would download but would never install. I tried several fixes online but it only made it worse. As a last resort, I backed up everything I could and tried to do a Factory Wipe/Reset. It wouldn't work, so I did a hard reset. It bricked my phone. I had all sorts of code written in red on my screen, and after powering it back on, it would not go past the AT&T logo. I figured it needed the ROM reloaded, but I was afraid to do anything that would void my warranty. I called tech support and he recommended taking it to a device service center near me, since it was still in warranty, or I could wait and have them send me a new phone and send this one back. I opted to drive to the service center because I couldn't be without my phone for who knows how many days it would be! The tech at the service center was very nice and he hooked up my phone and reflashed the ROM. It worked great after that, and he said if it was hardware that it would probably act up again within a week, and to not load anything on it for a few days to see if the symptoms returned. It's been a couple of weeks now and the symptoms have not returned.

However, I noticed something last night. Shortly after I got my phone, I learned about being able to connect a keyboard or a flash drive to my phone. I got an inexpensive OTG cable from Amazon and it took about a month to get here, but when I got it, I hooked it up and right away it recognized the cable. I hooked it up to both my wireless keyboard and my wired keyboard from my desktop PC, and they all worked great. I got a mini USB keyboard from Amazon to use with it when I'm out and want to do some writing. But when I got the keyboard and hooked it up, nothing happened. It works with my laptop, but since I got it to use with my phone, I decided to return it. To my surprise, Amazon said I could keep it since I was such a loyal customer and refunded my money. That was a few days ago. Then last night I decided to try it with a flash drive. It would not recognize the flash drive. I realized that I had not used the OTG cable since the reset, and that maybe it wasn't the mini keyboard that didn't work after all. I've never tried it with a flash drive. So as a test, I tried it with my wireless keyboard since I knew it had worked before. It didn't recognize it. And after doing some research online, I came across a post on here where it showed that it should actually recognize the OTG cable as soon as it is connected. I remember seeing it now, I can see it clearly in my mind, both at the top in the notification area and a screen overlay message at the bottom. I do not remember what my Android versoin was before, but now it is 4.3. And I don't understand why it doesn't work now. I downloaded the USB Host Diagnostic from the Play store, and also USB Host Controller. I don't understand everything it says, but from what the USB Host Diagnostic tells me, the device claims to support it but doesn't recognize USB devices.

Can anyone please help? I would love to be able to use the OTG capability again! :'( I've searched around the internet and I'm confused! If you've read all this, thank you!

Forum statistics

Latest member