"Use since last full charge" isn't resetting

johnatthebar

Well-known member
Nov 17, 2009
158
5
0
Visit site
I've noticed that my battery stats don't reset after a full overnight charge. I'm going to use a different charger tonight and see if it acts differently but I've used this charger on 2014 and 2014 Moto Xs, and a Nexus 5X without any issue.

Has anyone seen this before?

Posted via the Android Central App
 

Attachments

  • 5877.jpg
    5877.jpg
    27.6 KB · Views: 72

N4Newbie

Trusted Member
Nov 15, 2012
5,006
1
36
Visit site
I think you misunderstand the graph.

For example, "Screen = 37%" means that of all the power which has been consumed since the last full charge, the screen used 37% of it.

If you add all the percentages, you will see that they come to ~100%.

Think of it this way: If you have used a total of 1,000 mAh since the last charge, the screen used 370 mAh, Android OS used 150 mAh, Android System used 120, and so on.
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
I think the OP means that the stats cycle doesn't reset after a full charge, as it should. I would try wiping the cache partition on recovery, this process fixed a battery reading problem that I had on my previous phone. Worth a try.
 

johnatthebar

Well-known member
Nov 17, 2009
158
5
0
Visit site
I think you misunderstand the graph.

For example, "Screen = 37%" means that of all the power which has been consumed since the last full charge, the screen used 37% of it.

If you add all the percentages, you will see that they come to ~100%.

Think of it this way: If you have used a total of 1,000 mAh since the last charge, the screen used 370 mAh, Android OS used 150 mAh, Android System used 120, and so on.

Javier P is correct. I get how the stats work. The graph and stats should reset after a full charge is achieved, and that doesn't seem to be happening.
 

maverick7526

Well-known member
Jun 24, 2011
1,386
75
48
Visit site
Javier P is correct. I get how the stats work. The graph and stats should reset after a full charge is achieved, and that doesn't seem to be happening.

Wipe the cache partition as someone stated earlier, that should remedy the problem. Usually the stats reset once you go over 90 or 91%

Posted via the Android Central App
 

johnatthebar

Well-known member
Nov 17, 2009
158
5
0
Visit site
I cleared cache last night and the problem remains. Stats clear at the reboot point from the cache clear, but don't reset from the overnight charge. Will try and different charger tonight.
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
Re: "Use since last full charge" isn't resetting

That's strange. It shouldn't be related to the charger. Just to be sure, are you using any custom ROM or do you have any developer option enabled? I'll check with the Ambassadors team about this issue.

Edit. Are you using any battery saver or optimiser app?
 
Last edited:

Golfdriver97

Trusted Member Team Leader
Moderator
Dec 4, 2012
35,365
110
63
Visit site
Offhand, I am not sure myself. But something that really seems strange is the fact that it held onto that battery data after the phone was turned off for a few hours.
 

LeoRex

Retired Moderator
Nov 21, 2012
6,223
0
0
Visit site
This is concerning. The power system isn't registering that full charge as a full charge. Is the battery meter showing 100% and the phone saying "Fully charged"?
 

johnatthebar

Well-known member
Nov 17, 2009
158
5
0
Visit site
Offhand, I am not sure myself. But something that really seems strange is the fact that it held onto that battery data after the phone was turned off for a few hours.

Power cycling (from the cache clear) did restart the stats. Charging to full after that did *not* reset the stats.
 

johnatthebar

Well-known member
Nov 17, 2009
158
5
0
Visit site
That's strange. It shouldn't be related to the charger. Just to be sure, are you using any custom ROM or do you have any developer option enabled? I'll check with the Ambassadors team about this issue.

Edit. Are you using any battery saver or optimiser app?

I am on the stock ROM, not rooted. Dev mode enabled (but was just for USB debugging or something - I don't recall, didn't change anything at all).


This is concerning. The power system isn't registering that full charge as a full charge. Is the battery meter showing 100% and the phone saying "Fully charged"?

The meter does indeed show 100% once fully charged. As for saying, "fully charged" I'd have to check. That is just on the lock screen, yes?
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
Re: "Use since last full charge" isn't resetting

I've done a little search and found a report about a similar issue with the 6P. It seems related to a WiFi bug. Try this. Switch WiFi off, power the phone off, plug the charger and power on. Also, changing the WiFi band from automatic to 2.4 GHz fixed the problem for other user.

Ok, don't ask me why :) Worth a try.

https://m.reddit.com/r/Nexus6P/comm...t_resetting_after_full_charge/?ref=readnext_9
 

johnatthebar

Well-known member
Nov 17, 2009
158
5
0
Visit site
Re: "Use since last full charge" isn't resetting

I've done a little search and found a report about a similar issue with the 6P. It seems related to a WiFi bug. Try this. Switch WiFi off, power the phone off, plug the charger and power on. Also, changing the WiFi band from automatic to 2.4 GHz fixed the problem for other user.

Ok, don't ask me why :) Worth a try.

https://m.reddit.com/r/Nexus6P/comm...t_resetting_after_full_charge/?ref=readnext_9

The wifi power thing seems to have worked. I'll confirm after it works two nights in a row. Madness.
 

johnatthebar

Well-known member
Nov 17, 2009
158
5
0
Visit site
Update:
I realized after the WiFi off/charge/shutdown routine that while my batt stats reset, I also charged my phone with WiFi turned off all night. While this did show that one of these two actions work, I needed another test to see what made the difference. Ooops. Last night I charged the phone with WiFi on (as is my normal routine, home = WiFi). This morning, my batt stats hadn't reset. Bummer.

The next test will be to leave it manually set to 2.4ghz and see if that works, but as mentioned, I really hate compromising in this way. Am I correct in understanding that *most* 6P owners do see their batt stats reset after an overnight charge even if they have WiFi turned on?
 

N4Newbie

Trusted Member
Nov 15, 2012
5,006
1
36
Visit site
My Wi-Fi is always on and battery stats reset works as expected.

I will say that I have both 2.4GHz and 5GHz in my home and I have the phone set to connect to the 5GHz network as that one just seems to be more reliable.