Verizon Moto E: Bluetooth music cuts in and out - how to fix?

MikeSo

Active member
May 15, 2014
26
0
0
Visit site
When I listen to music or podcasts (I use Xbox Music and Podcast Addict apps) the playback is very choppy. It cuts in and out several times per minute. This happens on both my car bluetooth adapter (Kinivo BTC450) and my speaker at home (TDK A33).
Both of these play back music fine from my other phones (Lumia Icon and Lumia 635), so I think it's something with the Moto E they don't like, or vice versa.
Does anyone have any suggestions for how I can fix it? It's very annoying.
 
Last edited:

SpookDroid

Ambassador
Jul 14, 2011
19,231
465
83
Visit site
Does the stuttering happen with any app or just those two? Trying to narrow down the issue to app-specific problems or maybe it's the Bluetooth on your device...

You can try keeping the screen on and see if it stops (the Note 4, for instance, has a BT Stack issue and unless you keep your screen on, audio via BT 'skips' every once in a while...it's not several times per minute though, that sounds extreme).
 

MikeSo

Active member
May 15, 2014
26
0
0
Visit site
I tried it in several apps now, and it keeps happening. However, for a stretch yesterday it didn't happen for like half an hour. It also seems to be worse right after I start driving. I wonder if it is related to WiFi coverage or BT interference. It also seems to happen more while I actively use the phone.

I guess I'll keep trying and hope for the best.
 

SpookDroid

Ambassador
Jul 14, 2011
19,231
465
83
Visit site
Might be either interference from other devices (some traffic lights actually DO interfere with BT, especially when you're close!) or your device just not being able to handle the process load.
 
Feb 20, 2016
5
0
0
Visit site
I have the same problem, which I think is very common with Android phones and bluetooth headphones and speakers. I've done some searches and it seems there is no fix for it. The music on my Note 2 (Yeah, it's old) will always play great through my bluetooth earbuds for a few minutes and then it starts breaking up really bad ever few seconds like you stated. My iPhone works great with no problems.