Videos greyed out in gallery

Anna Chino

New member
Feb 28, 2023
2
0
0
Visit site
Hi!
I recorded some videos (4K 30fps and 1080p 30fps) on my Huawei P20Pro (emui 10.0.0.182).
I uploaded them to my computer, worked on them in Shotcut and used their default settings (codec libx264).
When I upload these videos back to my phone (to then upload the videos to social media, which can rarely be done from the desktop app) they are greyed out in the gallery. I've downloaded 5 different gallery apps but to no avail. I can play them with vlc player app, but that still doesn't mean I can upload my videos to social media.

I don't understand this problem. I use specs that in reviews work on Huawei phones, but it stubbornly doesn't on mine...

Are there any solutions to this problem?

I appreciate any suggestions at all!
Thank you in advance,
Anna
 

SpookDroid

Ambassador
Jul 14, 2011
19,279
528
113
Visit site
Do any other codecs work? If you can open it with VLC, have you tried sharing from there? However, I still think the codec being used is the problem here...
 

Anna Chino

New member
Feb 28, 2023
2
0
0
Visit site
Do any other codecs work? If you can open it with VLC, have you tried sharing from there? However, I still think the codec being used is the problem here...

I haven't tried uploading from vlc and I don't know how to do that yet. I cold learn, but I would much rather have the videos show up normally in the gallery as a standard... Is the codec I've used not the one that's recommended for videos?
 

Members online

Forum statistics

Threads
942,850
Messages
6,916,211
Members
3,158,692
Latest member
BlueSun