Voicemail Notification doesn’t go away after Lollipop update.

MarkSeven

Well-known member
Oct 19, 2011
283
1
0
Visit site
Ever since the 5.0 update on my Nexus 5 whenever I check my voicemail the symbol won't go away after I delete them & hang up. I always have to call it a second time and then hang up for it to go away. Any suggestions or solutions?

Posted via Android Central App on The Nexus 5
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,935
3,937
113
Visit site
Which carrier do you have? How long have you waited to see if the voicemail notification will disappear on its own? I'm on T-Mobile, and I notice that sometimes it takes a few minutes for the notification to go away.
 

Alain Levasseur

New member
Dec 7, 2014
1
0
0
Visit site
I've waited 2 days now, and it's still there. I've even done a factory reset and yet it still comes back. And yes, my voicemail IS empty and I have no saved messages. So frustrating...
 

Tre Robinson

New member
Dec 9, 2014
1
0
0
Visit site
I'm having this same issue. Phone = Nexus 5, Carrier = T-Mobile. I normally have to call my VM a few times to get it to clear. I tried to turn off notifications, but Lollipop doesn't have "Voicemail" as an available APP. When you long press on the VM and go to info, it comes up under "Phone." When you go inside Phone, it doesn't have a notification option that seems useful.

I went into Dialer > Settings and looked around there. I changed my voicemail from Carrier to Google Voice, just to see if I could change the behavior, but there was no change. It's pretty frustrating to be told you have a voicemail when you don't and not being able to manually clear it.
 

pirateghostabc

Active member
Oct 29, 2014
35
0
0
Visit site
I have ATT and I had some difficulty getting mine removed too. I had to go back into voice mail and make sure I deleted the voice message. You shouldn't have to do that.
 

Tom Lovett

New member
Dec 10, 2014
1
0
0
Visit site
Clearly a software issue as I have the same problem in the UK on O2. Very irritating as I am likely to miss a voicemail because I don't believe the notification.
 

robinhood1964

New member
Dec 16, 2014
1
0
0
Visit site
Similar problem here. I have an unlocked, Google purchased, Nexus 5 on Virginmobile Canada. The lock screen notification and the message icon stay on after all messages are erased. Restarting the phone will clear it. Very annoying. Virgin support said try calling my own number rather than the voicemail number to retrieve messages, but that didn't change the notification problem. Not happy.
 

tregrrr

New member
Jan 16, 2015
1
0
0
Visit site
Still have this problem too.

On telus in Canada and have had them manually reset the indicator server side. It worked...until the next time voicemail was deposited.

After reading the other posts I think it was the reboot of the N5 (Google proper version) that cleared it that time.

I have already missed messages. That indicator now gets as much attention as ads.... Slim to none, and Slim left last week.

Some attention to this international, multiple carrier issue would be nice. All these the carriers could all be wrong, yes, but lollipop teams have to consider the possibility that there might actually be an issue in how they are playing with the signals....
 
Last edited:

rewen

New member
Dec 3, 2011
1
0
0
Visit site
Same issue. Nexus 5 w/ Koodo in Canada.

I think it only happens if I hang up too quickly after deleting my voicemail. Reboot fixes it.
 

dansattel

New member
May 29, 2013
1
0
0
Visit site
Same problem here. HTC One M8 with lollipop 5.0.1. If I delete the voice mail and then reboot, the notification goes away. Very frustrating. I'm using unlocked with straight talk att Sim.

Posted via the Android Central App
 

Bcan17

New member
Feb 27, 2015
1
0
0
Visit site
The easiest way I have found to clear the voicemail icon is to force stop the phone/messaging storage app from the app listing (under the all tab) saves you a reboot. I'm with koodo in canada.
 

Mario Cg

New member
Apr 15, 2015
1
0
0
Visit site
To clear the voice mail notification when it will not disappear despite hitting the clear notification button, Go to settings, application manager, slide top bar to all, go to phone, open it and hit clear data and the voice mail notification notice will disappear.
:)
 

whoxp

New member
May 30, 2015
1
0
0
Visit site
Wanted to come on here and explain how I solved this problem on my Moto G using straight talk on lollipop 5.0 since no other solution has worked. So somehow when my wife left me a voicemail it told her the usual google voicemail subscriber stuff but afterwards the message actually went to my straight talk voicemail(just realized the mix up today). Which is weird since it was telling me in the notification to call my google voice number to listen to the message. After several weeks of the annoying notification I went to the google voice website to unsubscribe from google voicemail. Was told to dial ##004# and wait for prompt to complete. Notification was still there so I called my straight talk voicemail, noticed message... deleted... notification gone. Re-setup google voicemail and all is better.

Hope this helps some of you as clearing the phone app data and cache was only a temporary fix for me.
 

MarkATL

New member
Jun 3, 2015
1
0
0
Visit site
Similar solution for me. I signed out of Google Voice and then went through setup again. This did not resolve the issue however...I still had a notification for voicemail. What actually cleared it for me was to clear data on the Phone app in app manager.
 

eazl

New member
Jun 7, 2015
1
0
0
Visit site
SOLVED: I have att/straighttalk. Installed Google Voice on Nexus 6 and I had this issue. I had a voicemail notification that does not go away. The conversation suggested an issue with voice mail notification.

So google voice has its own voicemail # which is your google voice number
You provider has a different voicemail #

Solution: Call you previous voicemail number. For me on ATT was 401-369-6501
Access your voice-mail, listen or delete unheared messages on that system then exit

Once I did that, the voicemail notification was gone and can use google voice voicemail instead.

Hope it helps
:p
 

Trending Posts

Forum statistics

Threads
941,375
Messages
6,908,392
Members
3,157,888
Latest member
Wanderer