Weather/time widgets do not load on Galaxy S9+

eklisiewicz

Well-known member
Apr 27, 2010
198
5
18
Visit site
Hi, I am a new owner of an S9+. Have updated to Android Oreo and have tried adding weather and time widgets to both Nova Launcher and Evie. For Today Weather and Weather Live Pro, when I try to add a widget to the home screen, it throws this error:"Problem loading widget". EWeather works OK, but the widget is rather ugly.

I changed permissions for both Today Weather and Weather Live Pro, but that didn't help.

Is there a workaround? I spend all this money on a phone, and I expected something this simple to just work. I did multiple searches for this problem and tried some of the solutions but nothing has helped.

Any info is appreciated. In the meantime, I am using Stock Weather as it's the only thing besides EWeather that works for me. Thanks.
 

lucianus_luciferus

Well-known member
Sep 11, 2013
1,700
0
36
Visit site
Weather live widgets working fine for me on nova.
If the weather widgets are working with the stock launcher then I suggest reinstalling nova and make sure you are giving it the required permissions.
If the widgets are not loading on the stock launcher then reinstall the weather app.
 

eklisiewicz

Well-known member
Apr 27, 2010
198
5
18
Visit site
Hmm. I am not trying this with the stock launcher, but only on Evie and Nova. Will try reinstalling Nova as you suggested, and also trying weather widgets with stock.

The 1Weather widget works fine with Nova and I do like it pretty well. So if all else fails, I will stick with that.

Thanks.
 

eklisiewicz

Well-known member
Apr 27, 2010
198
5
18
Visit site
Weather Live does not work on stock for me. Today weather does work on stock. So there is something causing a problem with Weather Live. I am returning to using Nova. Not sure what the problem is but will give Nova the needed permissions.
 

eklisiewicz

Well-known member
Apr 27, 2010
198
5
18
Visit site
Have settled on the stock clock widget with the 1Weather widget. Both of those seem to work fine. It is just when I try to use a weather and clock combined widget that things do not work correctly. I notice problems like the widget not updating, problems reported by others. All apps have the correct permissions, so I am not sure what causes the problem. Thanks for the response here.