Weird SMS problem

NickUK172

Member
Oct 31, 2016
6
0
0
Visit site
Whenever I try and send a message it reports an error - "Sorry, the number you are sending to does not contain the correct number of digits"

Basically, using the default Messenger app, when I go to compose a new message and choose a contact from within the app, all of the contacts numbers now have 01144 instead of the usual 0 in front of the number for that person. So instead of 11 digits they have 15 and the message fails. Yet when I check the contacts in my phonebook they are all ok.

There seems no way to delete contacts from within the Messenger app or any way of editing them. I've tried disabling the Messsenger app and rebooting the phone, then re-enabling the app hoping the app will re-populate it's contacts from the phonebook contacts. But I still get the same issue.

Could this be an issue because I am in the UK and it is trying to add an international code before the numbers? The code for UK is 44 but I've no idea where the 011 would come into it. I've only noticed this since I updated to Marshmallow, I've never had this issue before, but I'm not sure if that's what's caused it as I tend to use other messaging apps rather than the default app.

Any ideas on what's causing it or how to solve it?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,529
4,667
113
Visit site
Open the Phone app, tap Menu>Settings>Call Settings, and see if there's an option to add the country code automatically. If you don't see it there, go to the system settings instead, under the Cellular Networks menu. Anything there?
 

NickUK172

Member
Oct 31, 2016
6
0
0
Visit site
Cheers for the suggestion. I found that particular setting in the phone book (Settings, Calls, Assisted Dialling) and it was set to United States, so changed it to United Kingdom, and made sure there were no prefixes to the numbers in the settings too. Rebooted the phone, and it's still doing it :(

Changed all the settings in the messaging app back to default, tried deleting all the contacts and conversations, but the same happens.

Went through all the settings on the phone looking for anything to help but couldn't find anything. All regional stuff is set to UK.

I did notice that the Marshmallow software version is - 24.81.5.en.US - Maybe that is just for the US and they haven't rolled out a proper international version yet?
 

NickUK172

Member
Oct 31, 2016
6
0
0
Visit site
Hmmm. I had no idea there was another Messaging app installed on the phone by default. I just assumed Message+ was the default phone one. Tried using the green "Messenger" app and it's now working!!

The Verizon Message+ must be the issue somehow.

Cheers for the suggestion though. I typed out a reply that for some reason isn't showing now! I found that setting you suggested and changed the Assisted Dialling setting to United Kingdom, but that didn't work.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,529
4,667
113
Visit site
Glad it's working! It's possible that the fact you're using a US phone with a US firmware in the UK is the reason why Message+ is doing that. I don't believe Verizon phones have anything besides US firmware. But as long as the stock Messenger app is working correctly, that shouldn't be an issue now!:)
 

NickUK172

Member
Oct 31, 2016
6
0
0
Visit site
Yeah it's weird, as I've had the phone a couple of years now and it has worked with Message+ previously. Must be something in the Marshmallow update that has region locked the app.
 

doogald

Trusted Member
Jan 3, 2010
4,425
55
0
Visit site
It is a Verizon proprietary phone with a Verizon messaging app, and Verizon never intended to sell this phone to anybody who wasn't on their network. So I'd consider it highly likely that they never tested this particular configuration. It's good to see that you found a way to make it work.
 

Trending Posts

Forum statistics

Threads
942,977
Messages
6,916,712
Members
3,158,757
Latest member
Hisoka_Ryuzaki