What can I do, process com.android.vending has stopped unexpectedly?


AC Question

process com.android.vending has stopped unexpectedly.

Okay, let me preface by saying I have been trying to find the answer to this question for weeks. I've clicked every link on the first five pages of google and they all suggest the same things.

Phone: Tracphone Samsung Galaxy S2
Android Ver.: 2.3.6 Gingerbread

The problem: Every time I try to access the Google Play Store, it crashes with the response "Sorry! The application Google Play Store (process com.android.vending) has stopped unexpectedly. Please try again".

What I think may have caused it: one day a few weeks ago my phone was being incredibly sluggish, so I was going through my applications to get rid of some to see if it would help. I also messed with Running Services, and I deleted some Youtube process that was running (it wasn't the actual app itself). I thought it was related to youtube and I don't care about or use that app particularly, so I deleted the process. That is when all of my troubles began. I don't know if that is related, that's just when google play stopped working.

What I've tried to fix it: I have done a factory reset at least three times, I have gone into Google Play Store app management and cleared the cache, I've cleared the data, I've uninstalled the updates. At one point today I tried to get into the store again and it had updated and let me in, but then I went to download an app (WePow Candidate), it asked me to enter my credit card info, I pressed skip and okay, then it said there was a server error... I looked that up, was told to uninstall google play store updates, I did that, and now I'm back at square one not being able to get into the program again.

This is really very frustrating and I have not been able to find a solution. So many seem to have this problem, but none of the solutions I've tried have helped me. Thanks in advance.


New member
Feb 20, 2016
Visit site
Re: process com.android.vending has stopped unexpectedly.

I just bought a Tracfone LG Optimus Dynamic and have the same problem. I added my google account and enabled sync but the Play Store never worked. My guess was maybe the pre-installed app was outdated since this is an older model phone, so I installed a newer APK version and it finally worked. In my case I downloaded Google Play Store 5.0.31 from APKMirror directly through the internal browser over wi-fi and clicked the notification to install. Also Settings > Applications > Unknown Sources was enabled but I don't know if that helped.

Unfortunately, the Tracfone My Account app won't install. It says "Your device isn't compatible with this version". And the available memory is very low until I get an SD card.

B. Diddy

Senior Ambassador
Mar 9, 2012
Visit site
Welcome to Android Central! Thanks for sharing your solution. Keep in mind that adding an SD card won't increase your ability to install apps--it's primarily for media storage.

Trending Posts

Forum statistics

Latest member