• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues please let us know in this thread!

Why am I having problems after unrooting my Galaxy S4?


AC Question

Just got an unlocked Galaxy S4 (original carrier is T-Mobile). Upgraded to 4.4 Kitkat.

I used Kingo Root to successfully root the phone. But, I realized that rooting the phone keeps me from using Android Pay, so I went to the Kingo App to unroot my device.

Apparently it's unrooted now, RootChecker even says so. But when I try to access OTA software update, I get an error message saying "The operating system on your device has been modified in an unauthorized way. Try downloading software updates using Samsung Kies on your PC, or visit a customer service center."

If my device is unrooted, why is this happening?

Also, I tried to use Android Pay after unrooting. It didn't work. Instead, my phone reset as I was standing at the register, and, when it started back up, my wallpaper was black, and there was an icon in the notification bar at the top of the screen that I've never seen before; a circle with a single diagonal line through it (like a block symbol). I just shrugged it off and powered off the phone and powered it on again. I also wiped the cache partition since it's recommended to do so every so often.

I haven't tried using NFC since, so I dunno if any of that fixed the issue I was having. The phone hasn't reset by itself at all since that one time though, and I still have no clue what that icon meant.

I feel like something bad is wrong with the phone now. What exactly is going on with it?