Why can't I enable Home or Work as trusted places with Smart Lock?

BruceWeber

Member
Oct 11, 2014
15
0
0
Visit site
I have Home and Work set up in Google Maps, but the option to enable them in Smart Lock is grayed out. I can enter them as custom places, which works fine. I'm just wondering why they I can't enable them as Home and Work. Thoughts?
 

vividrich

Well-known member
Jul 26, 2012
456
1
18
Visit site
Odd. I can enable them, but the feature doesn't work really well for me. It's routinely requiring me to log in anyway.

Posted from my Nexus 5 via Android Central App
 

daihard2008

Well-known member
Mar 26, 2012
325
0
16
Visit site
I am using Home and Work as my two trusted places. It works well in both places for me. FWIW, I use a pattern to unlock the phone.
 

Paddy Landau

Well-known member
Apr 9, 2013
48
0
0
Visit site
I'm in UK and my Nexus 5 doesn't even have a an option for places.
It's being rolled out worldwide (I'm also in the UK). The order of receipt appears to be random. It'll be with you soon.

It's a silent update, so you have to check every now and then; I don't know if you have to restart your phone.
 

Paddy Landau

Well-known member
Apr 9, 2013
48
0
0
Visit site
I have just been in a discussion with Google Support for this issue.

Here is the response, summarised because I was with them for a long time!

Method 1


  1. Go to Settings > Security > Clear credentials.
  2. Try again to set Home or Work as a Trusted Place.
  3. If that doesn't work (it didn't with me, because Clear credentials was greyed out), restart into Safe Mode and repeat. (To get into Safe Mode, hold down the power button until you see the "Power Off"; then press down on "Power Off" until you see the prompt to restart into Safe Mode; press OK. Get out of Safe Mode by restarting normally.)
  4. If that doesn't work (it didn't with me, because Clear credentials was greyed out), go on to Method 2.

Method 2



  1. Report the issue to Google Maps (yes, really), as follows.
    • Go to the Google Maps Help Centre.
    • Select Fix an issue > Report a problem.
    • Follow the instructions under Report a problem with the map.

I have not tried Method 2, because I don't have time right now. If you do, please let us know the response.

Method 3


  1. Settings > Backup & reset > Factory data reset. Warning: This will do a Factory Restore and you will lose ALL of your data stored on the phone. Ensure that you have a complete backup of everything before you proceed. (Data on the cloud will still be OK.) If you use Authenticator, VIP access or any other two-factor protocol, you'll need to ensure that you can log in to your various accounts without the authenticator apps before you do your factory restore.

I haven't tried Method 3, because I don't have time. Maybe over the weekend.
 

parkerhugh

New member
Feb 2, 2014
2
0
0
Visit site
I had same problem as described here, my Home and Work Locations were both greyed out and not available to select.

But my home and work locations are the same. So I went to Google Maps > Settings > Edit home or work

I removed my home address from Work and screen then said "Enter work address".

I went back to Settings > Security > Smart Lock and my Home address was now available to select as trusted place.

I think the reason both were greyed out and not previously available was because they were the same address and you couldn't enable one without the other.

Hope this helps someone else.
 

Paddy Landau

Well-known member
Apr 9, 2013
48
0
0
Visit site
But my home and work locations are the same…
So were mine.

They were the same because, when I left the Work address empty, Android kept filling it in with random addresses (addresses that I'd never even visited!).

However, I've copied what you have done and now it works. Thank you.

I subsequently returned to Google Maps and re-entered my Work address (the same as my Home address), and restarted my phone. It still works (although Smart Lock thinks that my Work address is still empty).

I have reported this bug; any reader who is affected by this should log in there and click the star.

EDIT: See next post
 
Last edited:

Tom Matheney

New member
Dec 25, 2014
1
0
0
Visit site
For me the steps above (deleting home/work then adding them back) worked, thanks. Perhaps something to do with enabling smart lock after entering home/work addresses, as I did when I first set up my phone.
 

jefferai

New member
Jul 26, 2012
2
0
0
Visit site
I have a slightly different but maybe related problem: Trusted Places doesn't show up at all. I have Play Services 6.5.99 so that shouldn't be an issue. I've tried removing Home/Work and re-adding just one of them...no dice.
 

grover5

Well-known member
Jan 23, 2013
461
0
16
Visit site
Odd. I can enable them, but the feature doesn't work really well for me. It's routinely requiring me to log in anyway.

Posted from my Nexus 5 via Android Central App

I have the same issue. If I leave home and return it doesn't remember home as safe and requires me to use my pattern password. But once I reboot the phone then it works again.

Posted via the Android Central App
 

Svensk Smith

New member
Jan 8, 2015
1
0
0
Visit site
Same issue here, my home deactivates itself in trusted places. It works one unlock and the second is locked again, If I look in trusted places home is disabled. Work place is doing fine though. I have tried pin and pattern...
 

menawati

New member
Jan 25, 2015
1
0
0
Visit site
Another thing to check.
Wasn't working for me either - I set Home as trusted in smart lock but still had to enter my passcode.
Then I noticed that my home address is actually at end of street on maps - I live in a weird cul-de-sac type place and google maps seems to believe my address is about 200 metres away. That is why it wasn't working (it would have actually unlocked at the end of the street if I walked there).

So, just reset your home address to it's actual geographical location or add a new trusted place at your current loc when you are at home (I did the latter and called it 'Home Loc' or something). Worked fine then.
 

spile1

Member
Dec 28, 2012
24
0
0
Visit site
Smart lock does not work for me when two user accounts are set on the device as the feature can only be turned on in one account.
Attempting to turn on Smart lock in one account results in smart lock being turned off in the other.
 

Paddy Landau

Well-known member
Apr 9, 2013
48
0
0
Visit site
Attempting to turn on Smart lock in one account results in smart lock being turned off in the other.

My experience with Smart Lock is that what you put the main account applies whichever account is currently using it.

Maybe you should report this as a bug.
 

mark_ck

New member
Feb 25, 2015
2
0
0
Visit site
I have a slightly different but maybe related problem: Trusted Places doesn't show up at all. I have Play Services 6.5.99 so that shouldn't be an issue. I've tried removing Home/Work and re-adding just one of them...no dice.

I had the same problem, encrypt your phone and it should show up.
 

Trending Posts

Forum statistics

Threads
945,767
Messages
6,927,055
Members
3,159,963
Latest member
krumplycelloids