Why can't my HTC One M7 call or text?

sandrik93

New member
Jan 18, 2014
2
0
0
Visit site
HTC One M7 can't call or text. Need HELP

I have an HTC One M7 unlocked version. Running CM12.1 now however there was the same problem on stock ROM (thought would fix if change)
Android 5.1.1
Baseband 4T.35.3218.16_10.33Q.1718.01L
Kernel: 3.4.105-gad476f8
M7-UL S-on
HBoot 1.61

Sometimes I have service and it works fine, but most of the times, either it shows that there is signal but it doesn't call or text(calls don't go through, text can't be sent) or there is no signal whatsoever. Suddenly started this a couple of days ago. Tried, reboot, factory reset, complete wipe with CM12.1 flash instead of stock. No change whatsoever. Any ideas on what the problem might be?
 

itguyjax8430

Retired Moderator
Mar 15, 2013
6,822
0
0
Visit site
Re: HTC One M7 can't call or text. Need HELP

I have an HTC One M7 unlocked version. Running CM12.1 now however there was the same problem on stock ROM (thought would fix if change)
Android 5.1.1
Baseband 4T.35.3218.16_10.33Q.1718.01L
Kernel: 3.4.105-gad476f8
M7-UL S-on
HBoot 1.61

Sometimes I have service and it works fine, but most of the times, either it shows that there is signal but it doesn't call or text(calls don't go through, text can't be sent) or there is no signal whatsoever. Suddenly started this a couple of days ago. Tried, reboot, factory reset, complete wipe with CM12.1 flash instead of stock. No change whatsoever. Any ideas on what the problem might be?

Welcome to Android Central!

Have you tried flashing a different baseband?
 

Bill Bowser

New member
Aug 11, 2015
1
0
0
Visit site
I have been having the same problem on an ATT M7. It started several months ago and I can't find a solution. The phone will just disconnect from the network(no phone, no internet, no text) even though it shows signal bars. Sometimes shows no signal. I've even seen it go from signal bars to no signal with an X back to signal and connect to the network by itself. It might work for weeks and then fail 3 or 4 times in one day then work for weeks again.

Here is what I have tried:
restarting the phone. This seems to work every time but problem comes back anywhere from minutes to weeks.
resetting the phone.
Called HTC and reflashed the rom; didn't work.
HTC worked with me to put the phone in safe mode but problem not solved. Just to see if an app was causing it.
Put a new ATT sim in it. Didn't work. Failed in minutes afterwards.
Called ATT 4 times to ask for help but they say it is not the Network

If you find a solution please communicate it. I'm out of ideas.
 

sandrik93

New member
Jan 18, 2014
2
0
0
Visit site
I haven't tried to flash a different baseband. However, my phone started to work. I didn't do anything. For past three weeks it works like a charm. Not guaranteed that this is not gonna happen again though..
 

Trending Posts

Forum statistics

Threads
942,938
Messages
6,916,578
Members
3,158,748
Latest member
Randomname09