Why does my Galaxy S5 keep restarting with a new SIM card?

androiduser546

New member
Jan 31, 2019
2
0
0
Visit site
I am studying abroad this semester in Senegal, and was hoping to get a local SIM card to use in my phone here, as the service/data is much cheaper that way than purchasing an international plan. I purchased a SIM card from Orange and popped it in. Booted up my phone, and it loaded up to the lock screen like normal. However, after several seconds the screen went black and I once again saw the animated Samsung logo. It loaded up to the lock screen and then repeated the process. It keeps doing this over and over; I believe it to be a firmware issue. I have tried multiple avenues to remedy the problem: changing my network settings under "More Networks", deleting most apps that did not come with the phone, making sure there is no SIM card lock pin enabled, and simply reinserting the SIM card. Nothing seems to make any difference, and I am ready to try messing around with the firmware. Any other ideas or advice?

Extra note: I have been told by my phone carrier in the US (Verizon) that my phone is indeed unlocked.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,953
5,264
113
Visit site
Welcome to Android Central! Just to be clear, this is the Verizon-branded S5, right? Since Orange in Senegal doesn't have LTE, what if you go to Settings>Mobile Networks>Preferred Network Type and make sure only GSM is selected (as opposed to LTE)?
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
And not CDMA, which is what the Verizon version would probably have been set to. (Luckily, the Verizon S5 has GSM also - not all CDMA phones of that vintage did. Even the US Cellular version of the S5 didn't.)
 

androiduser546

New member
Jan 31, 2019
2
0
0
Visit site
Yes, it is the Verizon-branded S5. To respond to both your replies, I've tried the Orange SIM card with all the different settings under "Preferred Network Mode" and it hasn't made any difference. Fyi, the three options on my phone are "Global", "LTE/CDMA", and "LTE/GSM/UTMS". There is no option that is solely GMS. I don't know if this is important, but whenever I hold the power button, pull up the menu and choose "Power off", it does the normal powering-off animation, screen goes black (as it should), and then it proceeds to start to show the scrolling Samsung logo, like I didn't just tell it to turn off! It doesn't get all the way through the animation, just does part of the logo and then the screen goes black and it's off as it should be. Also I've tried putting my phone in airplane mode with the Orange SIM card in, and it does the same thing, restarting over and over until I turn it off. Makes me think it's not a network issue. Thoughts?
 

Forum statistics

Threads
944,488
Messages
6,922,987
Members
3,159,580
Latest member
Vyrd