Why does my Samsung Galaxy Light keep turning on wifi and data?


New member
Jan 24, 2016
Visit site
Hello! I just acquired a Samsung Galaxy Light (branded to metroPCS, now unlocked and rooted, running Android 4.4.2). While setting it up over the last few days, I've noticed that the wifi and/or LTE come on apparently at random, despite my best efforts to disable them. I frequently travel using pre-paid SIM cards with limited data plans, and when I'm away from home, I generally need to conserve as much battery as possible. Whatever keeps flipping my data and wifi switches without my knowledge is seriously unwelcome. Sometimes it happens while the phone is in sleep mode, sometimes when I unlock, sometimes when I'm using it (never the same app twice), and almost always when I recycle the power.

Here are some of the things I've tried so far:

Settings>Wifi> Set to 'off'. "Smart network switch" (which allows the phone to flip between data and wifi independently) is also 'off'.
Settings>Wifi>Advanced>Always allow scanning 'off'. Keep Wifi on during sleep 'always' (I also tried 'never'). Network notification 'off'. Passpoint 'off'.
Settings>Data usage>Mobile data 'off'. Data roaming 'off'. Restrict background data 'on'. Auto sync 'off'.
Settings>More Networks>Mobile Networks>Mobile data 'off'.

I have disabled automatic updates in the Google Play Store and for any individual apps I can see. I have disabled notifications for all apps. I keep checking the active processes and for a while I thought maybe it might be something to do with Google Play Services, but I disabled DeviceConnectionServiceBroker and GCMServices just to see, and the LTE came back on anyway.

I ran a full scan with Malwarebytes. Nothing came back hinky.

I freely admit I'm not great with phones and I'm mostly flailing around here, but I don't know why this is so hard. I've tried searching the web and can't find a solution that works. A lot of threads suggest unchecking "Connection Optimizer" in wifi settings but the closest I can find on this phone is the "Smart network switch" and that was no dice. Just now while I was checking my phone to get the proper names of those Google processes, the wifi enabled itself again. I'm sure the LTE won't be far behind.

I throw myself on the mercy of the internet. Has anyone encountered this before?

Trending Posts

Forum statistics

Latest member