why i can't block incoming calls on my Nexus 5X?

eaccentsac

Well-known member
Jun 9, 2010
520
0
0
Visit site
In the call log, tap the number you want to block, then tap call details, then tap block number--confirm in the next screen.
 

PhiPsi32

Well-known member
Feb 21, 2011
1,354
4
38
Visit site
Make sure your dialing app is updated. The older version doesn't have call blocking. Otherwise you can block calls as above. You can also open the dialer app settings menu. There is an option for call blocking. You can manually add numbers.
 

eaccentsac

Well-known member
Jun 9, 2010
520
0
0
Visit site
Make sure your dialing app is updated. The older version doesn't have call blocking. Otherwise you can block calls as above. You can also open the dialer app settings menu. There is an option for call blocking. You can manually add numbers.

I got a Dialer update today. Haven't noticed anything new, but definitely recommend making sure the Dialer app is up to date.
 

Pirate Arr

Well-known member
Oct 13, 2013
131
0
0
Visit site
What sucks horribly is that you can't block private numbers even with the new phone update that allows you to block numbers. An area where Windows Phone wins in regards to Android.

Posted via the Android Central App on my Frost Nexus 6P
 

Bob Garon

Well-known member
Oct 19, 2015
95
0
0
Visit site
Where do you get the updated dialer because the Play Store shows that I am up to date and yet I still do not have the option to block in the call details as you mention?

Posted via my Nexus 5X & T-Mobile Unlimited
 

Bob Garon

Well-known member
Oct 19, 2015
95
0
0
Visit site
What happens when you long press the number in your call history? Dialer app is Ver 2.3.17

Mine was version 2.21 and Play Store says up to date. But I downloaded the updated version from Apk mirror and everything is working. Thank you!

Posted via my Nexus 5X & T-Mobile Unlimited
 
Last edited:

Forum statistics

Threads
943,023
Messages
6,916,939
Members
3,158,784
Latest member
sterrekroesbergen