Why is my 5.0, doing so poor on public wifi (specifically Virgin Media on the London Underground)?

mpradford

New member
Nov 27, 2014
1
0
0
Visit site
5.0 and public wi-fi (specifically Virgin Media on the London Underground)

Hi,
Over here in London, there's a free wifi service provided by Virgin Media. It's nice and simple, you sign up, the first time you go online in the morning an annoying ad pops up, you clear that tab and then you can browse and load pages or tweets etc. Since I upgraded, the connection to the Wi-Fi take a matter of seconds, but the loading of pages can take minutes. It used to be that at each station, when the connection is remade, a link or to could be loaded up, ready for reading. Now it's so slow nothing loads at all on the journey. Can anyone shed any light on what might be causing it? It's solely the change to 5.0 that seems to be a problem. Oh, also, the Wi-Fi connection symbol has an exclamation mark next to it the whole time, even though in settings it says I'm connected. Any help greatly appreciated.

Thank you

Radders
 

TheArchedOne

New member
Jan 12, 2015
1
0
0
Visit site
Re: 5.0 and public wi-fi (specifically Virgin Media on the London Underground)

Hi Radders,

Did you manage to fix this?

I get the same (or similar) on my Nexus 4. Pre-lollipop, the behavior was:

  1. Phone detects Virgin Media London Underground WiFi
  2. Notification appears (swipe down from top of screen) asking if you want to want to log in to Virgin WiFi.
  3. Tap the notification and browser opens Virgin media login page and logs on. (Alternatively, instead of tapping the notification, you could open any web page in the browser and it would redirect to the Virgin media login page and login.)
  4. Happy browsing for the entire journey (at stations only of course).

Since updating to Lollipop (5.0 and 5.1) the behavior is very unpredictable. Sometimes the "login to WiFi" notification appears as the phone detects the WiFi network. When clicked, it launches a different window (not the browser) and then successfully logs in and all is good. However, most of the time, the notification does not pop up for several stations and in some cases - never at all. The WiFi status shows that the phone is connected to the Virgin WiFi, but has an exclamation mark beside it (presumably because its not logged in). All web pages simply hang (no error message) because the phone can't access the internet. I've tried closing the browser, disconnecting / reconnecting WiFi, but nothing seems to work.

Seriously considering downgrading to KitKat because of this and general performance problems with Lollipop, but would prefer to persevere and fix the issues if possible.

TAO
 

dan1431

Well-known member
Mar 29, 2010
389
8
0
Visit site
Re: 5.0 and public wi-fi (specifically Virgin Media on the London Underground)

Interestingly, while visiting London, I tried to use the Underground Wi-Fi to no avail.

I figured that since I am from the USA and thus didn't have a Virgin Media account that was my issue, but maybe it is something with Lollipop.

Dan

Posted via the Android Central App
 

Forum statistics

Threads
945,657
Messages
6,926,499
Members
3,159,935
Latest member
CR5