Why is my Moto X having new wifi issues?

ILoveMyMotoX

Member
Sep 7, 2014
5
0
0
Visit site
My Moto X has new WiFi issues!

Hi there Moto X community!

My Moto X has never ever had any problems like this, but recently it will not connect to my high school's free unsecured Wi-Fi. It shows up in the WiFi menu as "saved", but when I tap the name to connect, it will say "Connecting" and the network strength will drop RIGHT WHEN I TAP, then the status goes back to "Saved" and the network strength comes back full force.
My friends' phones never have this problem (most have phones by Apple, Samsung, HTC) but this has been going on for me for like a week and I've nearly eaten through my data plan :-!

Details:
Moto X (2013) Unlocked XT1053
Factory OS 4.4.3, Upgraded to 4.4.4
The phone is about 4 months old

NOTE: This is the SCHOOL's WiFi so I can't do anything there.

UPDATE: I found the exact same issue listed in the Android L code...Look up Issue 78702 on the code tracker for AOSP. I can't post links
 
Last edited:

MarkHirt

Well-known member
Feb 7, 2010
110
6
0
Visit site
Re: My Moto X has new WiFi issues!

I'll be that in your Wi-Fi settings you have "Avoid Poor Connections" checked. No actual internet connection = Poor connection
 

Bryant Graves

New member
Nov 26, 2014
1
0
0
Visit site
Here is how I fixed my problem. Touch settings, then touch wifi settings, then touch advance, scroll down to auto connect and un-check the box then go and reenter the password for the hot spot and it will stay connected.
 

Trending Posts

Forum statistics

Threads
941,387
Messages
6,908,533
Members
3,157,897
Latest member
driodPixel