Why isn't my S4 Bluetooth answering incoming calls on my 2013 Kia Optima?

Doug Meade

Member
Jan 14, 2014
6
0
0
Visit site
S4 Bluetooth Phone issues with 2013 Kia Optima

Ok folks... have a weird bluetooth issue.
Any and all suggestions are appreciated.

Important things to note:
  • I have an AT&T Glaaxy S4
  • I'm pairing it with a 2013 Kia Optima (SX-L)

The pairing process works just fine.
The streaming of audio works just fine.
The PHONE though is having the following problems.

1) I can successfully make or receive ONE phone call through the car.
After that one call the car will still make or receive the call (it shows as connected and the call timer starts ticking)... but I can't hear anything and neither can the person on the other end.

2) Can't seem to answer incoming calls from the steering wheel.

What I've tried:
  • Rebooting the phone after the first successful call will let me make/receive one more. But wow what a pain in the ***.
  • Turning bluetooth off and back on after the first successful call does NOT.
  • I've updated the phone (still at 4.4.4) - no luck
  • I've un-paired and re-paired - no luck
  • I've downloaded the "SoundAbout" app - no luck
  • Disabled the "S-Voice" app..

Any ideas?
Thanks!
 
Last edited:

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
163,621
2,279
113
Visit site
re:

Welcome to Android Central! You don't have any other Bluetooth calling devices (like a headset) in the car as well, do you?
 

Doug Meade

Member
Jan 14, 2014
6
0
0
Visit site
re:

Nope.

From time to time I wear my moto360 which is a bt device. Its not a headset type device but it is also paired to the phone. ... but the problems persist even when no Other bt devices are present.
 

Doug Meade

Member
Jan 14, 2014
6
0
0
Visit site
re:

Thanks a bunch dm3ready.
I had already disabled S-voice with no luck... but hadn't considered the "google now" stuff being the culprit.
I'll try it out later today when I'm back at the car and report back.
 

Doug Meade

Member
Jan 14, 2014
6
0
0
Visit site
re:

That seemed to do the trick!

Per the thread dm3ready linked to I went into the Google Now settings and disabled the "Ok Google from any screen" option and things seem to be working now.

Thanks a bunch dm3ready!!
 

teamfoster03

Active member
Mar 6, 2011
32
0
0
Visit site
Re: S4 Bluetooth Phone issues with 2013 Kia Optima

I just updated google now and had the same issue. I had disabled google now voice detection from any screen but after the update it was turned back on. Guess this bug still isn't fixed.

Posted via Android Central App
 

Trending Posts

Forum statistics

Threads
936,958
Messages
6,881,063
Members
3,155,546
Latest member
mxyzb