Why my galaxy s5 won't turn on?

jinrah

Member
Feb 14, 2016
18
0
0
Visit site
hello guys, please help me with my galaxy s5. the problem is it won't charge and it keep on saying "battery temperature too high or low. i tried to change the battery but the same problem exist. any suggestion or help please. thank you and God bless.

12442872_1271581569536935_517446993_n.jpg
 
Last edited:

nahoku

Well-known member
Jan 26, 2013
3,300
0
0
Visit site
Sounds like a thermal sensor is bad on your phone. I know you tried a different battery, but have you tried a different cable/charger? Any battery monitoring apps installed on your phone? If so uninstall them to see if it makes a difference. You could download Aida64 to check the battery temp... not that it'll do anything to help you fix this problem, but at least you can see what it is in case you need to contact Samsung or your carrier for support.

What happens if you start your phone in Safe Mode. Does the popup still show up when you try to charge your phone?

As a last resort you may need to do a factory reset (if this is a software problem rather than hardware). But before you do, you will need to back up all data because a factory reset will surely wipe the phone.

EDIT>>> By the way, I just noticed that the context of your post doesn't match what the title states. Does your phone not even turn on?
 

jinrah

Member
Feb 14, 2016
18
0
0
Visit site
i tried everything. factory reset, changing my charger, changing battery as i said before, opening in safe mode, changing firmware, but all of these didn't solve the problem.

about the Title im so sorry im in a hurry, sounds like weird but its true. i just badly need my phone to get on charging.
 

nahoku

Well-known member
Jan 26, 2013
3,300
0
0
Visit site
Well, judging from what you're saying, it must be a hardware problem... either charging module or motherboard. Searches indicate it's not an unusual problem, and fixes range from reseating the charging module flex cable to replacing the charge module itself. Not sure what direction you want to take... send it in for repair, or brave it and do it yourself. Parts are available on-line... one guy said a board on ebay cost $7 and fixed his problem.`
 

jinrah

Member
Feb 14, 2016
18
0
0
Visit site
much appreciated brother. thanks for your help. do you think its a mother board problem or the module flex cable? because there are many sensors that are not working. the barometer and also gyroscope isn't working.
 
Last edited:

nahoku

Well-known member
Jan 26, 2013
3,300
0
0
Visit site
I really have no clue what part is causing the problem. Maybe the best remedy will be to visit a repair shop and ask for their opinion.