Wi-Fi suddenly slow on my Honor 8

A

AC Question

Hi

I bought my honor 8 two months ago, and it was working fine until this morning. The internet through the wi-fi connection suddenly became slow. It works for my girlfriend's phone, and both of our laptops, and my phone works fine in other wi-fi networks. This problem is only with our home wi-fi. I checked the speed with speedtest app, and after about two minutes of waiting, it showed the right speed, but surfing is painfully slow.
I did a hard reset on the router, and a cache wipe on my phone, but did not hard reset my phone, because it works on other wi-fi networks.
So my question is: what do you think is the problem?

Thank you for your answers!
 

Guytronic

Well-known member
Nov 9, 2013
1,306
1
0
Visit site
I'd try rebooting the phone (not resetting) or resetting your home wifi router (unplug wait 10 seconds then plug back in)
 

p1574

Member
Jan 12, 2017
6
0
0
Visit site
I'm OP

Thank you, but I already rebooted my phone several times, and even did a cache wipe, and I already rebooted, and resetted the router several times, and still no luck.
 

p1574

Member
Jan 12, 2017
6
0
0
Visit site
Disabled. I always disable my mobile data and enable wi-fi manually when I get home, because my mobile data isn't unlimited.
 

Guytronic

Well-known member
Nov 9, 2013
1,306
1
0
Visit site
I'll ask around and see if another 8 user has the answer.

Maybe someone in Honor 8 forum can figure out what's happening.
 
Last edited:

orangecroc

Trusted Member
Nov 2, 2016
1,050
0
0
Visit site
Try getting your phone to "forget" your network and add it again. Or if you can access your router interface, remove your device from the routers device list and then reconnect.
 

digitalbreak

Trusted Member
Jun 13, 2013
1,451
0
0
Visit site
Do you have a router that has dual band and smart connection feature which switches band automatically for a device based on its usage?

It could also be a router problem.
 

p1574

Member
Jan 12, 2017
6
0
0
Visit site
My router only has one band, and I didn't find anything about smart connection in the settings, so I guess it doesn't have that feature. Also I did a hard reset on my phone out of frustration, and it didn't help.
 

p1574

Member
Jan 12, 2017
6
0
0
Visit site
Thank you, but my problem is that the connection is slow on my phone, not that I can't connect. And It was good until yesterday, and no settings have been changed. That's why I don't have a clue about what's the problem.
 

p1574

Member
Jan 12, 2017
6
0
0
Visit site
Thank you for all your advices, but I honestly tried everything. I hard resetted my router and phone, I went through all the settings, and still the same. At this point I'm just waiting for a miracle.
 

Tim Chiang

New member
Feb 17, 2017
1
0
0
Visit site
Hi, how did you fix the issue? my phone have the same issue started a couple weeks ago. The wifi is very slow or totally can not open a webpage after a while, while the connection is good, and other devices work very well meanwhile.
 
Last edited:

madamocta

Member
May 7, 2013
22
0
0
Visit site
I don't know if this will help, but the same thing happened on my Sony tablet, can't find a solution (tried factory reset etc). Also happens occasionally on my Honor. Only solution is to turn the WiFi on the device off and then back on. That helps for a few hours. My guess is that the issue is with Android in general, not related to the device, because the issues on my tablet started when I updated to Marshmallow and Honor came with it.