Wifi issue - Says Connecting.. but never does. Has anyone seen this?


AC Question

Wifi issue - Says "Connecting..." but never does.

I have tested my phone on 4 networks.

1. Home network
2. GF network
3. Work network
4. Local Store network

1. Works fine and connects with no problem.
2. WAS working fine for 1.5 years. Now it says "Connecting..." then it does nothing, then goes back to "Saved, secured with WPA2"...then loops all over again.
3. Same as 2.
4. Same as 2.

Notes: Any other network seems to work fine. At first I thought I was blacklisted at work, but that can't be the case since it does the same thing on 3 of the 4 networks.

One thing I did notice is the signal strength starts at full bar but when it says "Connecting..." it drops to nothing then it comes back to full strength when it states "Saved, secured with WPA2". I tried different fixes from this forum, made sure the passwords are correct. Factory reset the phone, and as soon as I did the reset, I tried to connect to one of those networks. 1 works fine, 2,3,4 are a no go. So many fixes have been done and still nothing. I think it might be the radio in the phone. Any suggestions or ideas? Is this one of kind issue or has anyone seen this before? Thank you all for your time.


New member
Jul 28, 2015
Visit site
You may want to change the router settings by going to 192dot168dot1dot1 (or your default gateway) and change the wireless mode to mixed , sometimes it's set to n-only or something , if that doesn't work , try changing channels if your router supports , and your authentication to WEP .