Wifi keeps turning on whenever an application needing internet is opened

asifonline

New member
Aug 19, 2013
3
0
0
Visit site
I am having this weird situation with LG Spectrum2. After I turn the wifi off, whenever an application is opened that wants to connect to the internet, the wifi is turned on by itself, without asking any permission for it. I tried to check/uncheck the notification option but it does not work. I wonder if anyone could help on this.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
163,542
2,169
113
Visit site
Go to Settings/Wi-Fi, and see if there is a setting for "Auto-Connect to Wi-Fi," and if so, make sure it's unchecked.

Edit: Actually, I found the setting. Go to Settings/Wi-fi/Optimize Wi-fi usage, and uncheck "When launching apps, connect to known Wi-Fi networks when Wi-Fi is off." Found it looking through the manual, which can be downloaded here: LG VS930 Support: Find Manuals & Warranty Info | LG USA
 

asifonline

New member
Aug 19, 2013
3
0
0
Visit site
Thanks for your response, I have already unchecked the option 'When launching apps, connect to known Wi-Fi networks when Wi-Fi is off.' but it does not seem to have any effect. As soon as I open an application that requires internet, wifi just turns on by itself...
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
163,542
2,169
113
Visit site
Have you tried rebooting after unchecking that option? Also, do you have any kind of automation app installed that could be automating certain processes?

Posted via Android Central App
 

asifonline

New member
Aug 19, 2013
3
0
0
Visit site
I tried rebooting after unchecking that option but it didn't work either. I tried one other thing and luckily it worked. When the wifi reconnects, a notification appears with three options telling that the internet has been reconnected. I don't remember the first two options at the moment because the message didn't appear again but i clicked the third one that said, ' turn off wifi and connect through cellular network.' and that has worked for me. As I only use internet through wifi and have not configured it through cellular network, so this has worked for me. Wifi does not reconnect now. Thanks for sharing your tips here..