WIFI vs 4G battle on K20

mgnet

Member
Feb 8, 2011
16
0
0
Visit site
Hello, hope someone can help me.

I have a LG K20 metroPCS native.

It recently received an over the air system update, I refused to upgrade for as long as I could but eventually the upgrade went through and installed itself.

Ever since it has been hell trying to keep this phone connected to my house wifi router and separate cable modem setup. I do not go anywhere else to connect to Wi-Fi so am not sure if this is an issue only at my house.

The problem is that, the function to do the tmobile voice over IP is completely gone, not sure how to even activate it.

It keeps disconnecting from my wifi router, and going back to 4G which the signal at my house is really bad, I need the WiFi.

As soon as I go to the WIFI menu it finds my wifi network, I click forget it, reconnect to it no problem, but as soon as I go out of the WiFi setting, it drops again.

I have tried to reset my network settings but no difference.

Lastly, I activated the airplane mode to force the phone to avoid the 4g network, and only then it keeps connected to wifi workout ever droping it.

This tells me there is an issue with this phone favoring the 4g network over wifi.

I have gone to the wifi menu and set it to not to switch to 4g even if wifi is weak but no help there either.

Am exhausted, can anyone help?
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
Re: LGK20 Wi-Fi issues please help

Is there a MetroPCS near you? If there is, go to them. They can connect your phone to their wifi to see if it holds the connection. Or you can go to a McDonald's, Walmart, Starbucks or anyplace that offers free wifi.

You have to isolate the problem first - is it having a problem with wifi or is it having a problem with wifi calling?
 

mgnet

Member
Feb 8, 2011
16
0
0
Visit site
Re: LGK20 Wi-Fi issues please help

From what I been reading, there is a virus that is causing that, now I just have to figure out how to find and delete this virus without having to reset the phone.

Nothing else to isolate, the issue is clear, in order for the phone to hold wifi connection the 4g data must be eliminated using airplane mode, otherwise the phone will drop the wifi to use 4g instead.
 

mgnet

Member
Feb 8, 2011
16
0
0
Visit site
Re: How to activate wifi calling?

Yep I figure all that out, but I still have the issue that the phone will always want to go to 4g instead of wifi. In order to stay in wifi the phone has to be put in air plane mode.

I been reading there are a set of virus known to cause that, how can I clean my phone from viruses without having eerase reset the phone ?

7434819ff7cb8a6f0f82dce95f39cba6.jpg
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,982
5,297
113
Visit site
I merged your similar threads into one, so that there aren't multiple discussions going on about the same issue.

What is that screenshot from?

Can you tell us exactly how you know that the phone prefers 4G over wi-fi? Does the wi-fi icon in the status bar go away? Or does the "T-Mobile Wi-fi Calling" in the status bar change back to "T-Mobile"?
 

mgnet

Member
Feb 8, 2011
16
0
0
Visit site
Conclusion...

I installed AVG antivirus and cleaner

It not only scanned my found, but it also manipulated other settings and now magically the WIFI issue is gone, I keep Wi-Fi on all the time, when am away from home it uses 4G data, but when I come home it auto connects to Wi-Fi and maintains the connection.

Not sure why it stop working, but am glad is back on working.

While trying to fix this issue, I disabled a whole bunch of stuff/apps, now my weather widget is gone and don't know how to get it back :(