Wileyfox Swift 2 Plus doesn't recognise microphone of earphones

  • Thread starter Android Central Question
  • Start date

Android Central Question

Hey everyone! I have a Wileyfox Swift 2 Plus with android version 8.1.0.

It recently became necessary for me to make phonecalls while on the go. I noticed that whenever I plug in a headset (of any kind, I have tried different brands in attempt to solve this issue) the phone fails to recognise/use its microphone while playing the audio just fine.

In other words I am able to hear the other person through the headset, but they cannot hear me because the phone (in my pocket during the call) still uses its own microphone.

Can someone please help me solve this? I unfortunately don't have the luxury of stopping to make the call so I really need to use a headset.

Thank you so much in advance ! <3

B. Diddy

Senior Ambassador
Mar 9, 2012
Visit site
Welcome to Android Central! I know this is unlikely, but are all of the headsets you tried specifically "Made for iPhone"? If you see that label on its packaging, that can mean more chance of incompatibility with non-iOS devices.

If they're not all Made for iPhone, then use a can of compressed air to blow out any debris in the jack, and use a Q-tip dipped in rubbing alcohol to clean the contacts inside the jack.

Forum statistics

Latest member
yash ff