Will a Virgin Mobile Galaxy S3 work with a Sprint firmware installed on it?

udderjuice

Member
Oct 22, 2011
8
0
0
Visit site
So I have a Galaxy S3 from Virgin that I have been very please with. This morning I got a message that there was a system update to install. So I did (I'm not sure if this was upgrading to Kit Kat or what) and once it did I could not get it to boot past the Samsung logo. I tried everything, clearing the cache, recovery through Keis (which would not communicate with the phone or recognize my phone's serial number) and finally a factory reset.

Still stuck on the Samsung logo every time.

So I went to the Samsung website, downloaded the latest firmware for my model phone (which said "Sprint" in the description but they ALL did so I didn't have much choice). I installed it using ODIN and it finally booted up and I started installing my Google stuff. Only I noticed the lock screen now says "Sprint" on it and there is an option for Sprint Hotpots in the settings which was not there before.

I can make calls with it, even with wi-fi turned off but I don't see a 4G or 3G symbol in the status bar.

Have I majorly screwed up?
 

srkmagnus

Retired Moderator
May 23, 2010
13,433
210
0
Visit site
So I have a Galaxy S3 from Virgin that I have been very please with. This morning I got a message that there was a system update to install. So I did (I'm not sure if this was upgrading to Kit Kat or what) and once it did I could not get it to boot past the Samsung logo. I tried everything, clearing the cache, recovery through Keis (which would not communicate with the phone or recognize my phone's serial number) and finally a factory reset.

Still stuck on the Samsung logo every time.

So I went to the Samsung website, downloaded the latest firmware for my model phone (which said "Sprint" in the description but they ALL did so I didn't have much choice). I installed it using ODIN and it finally booted up and I started installing my Google stuff. Only I noticed the lock screen now says "Sprint" on it and there is an option for Sprint Hotpots in the settings which was not there before.

I can make calls with it, even with wi-fi turned off but I don't see a 4G or 3G symbol in the status bar.

Have I majorly screwed up?
I'm pretty sure Virgin uses the same devices as Sprint. Although you don't see the data icons, do you have a data connection?
 

Trending Posts

Forum statistics

Threads
945,889
Messages
6,927,528
Members
3,159,999
Latest member
possible11