Would like help upgrading from 4.4.2 to newer firmware

rb20100

New member
Feb 24, 2017
1
0
0
Visit site
I bought a Galaxy S5 from a cellphone repair shop. I wanted to upgrade to 6.0 but when I went to Smart Switch it say my phone is up to date, OTA error says failed to communicate with server. Please try again.
Here is my details per Phone Info
1. Model# SM-G900T, android version 4.4.2
2. Latest Firmware= Not found, also #1234 # gives error= connection problem or invalid MMI code. PDA Version= G900MUBU1AUMS. CSC Version= G900MUUB1ANCE. Baseband Version=G900TUVU1ANCH. Product Code= SM2G900TZWAATT
3. Original CSC Code= ATT. Firmware's CSC Code= TTT. Active CSC Code= ATT/TTT. Availiable CSC Code= TTT
Device Type kltetmo. Product Name kltetmo.
4. Carrier Metro PCS. Country USA. Root Existence= No. Under Settings, About Device, Device Status= Custom
Details per Genuine Galaxy says Congradulations! It is a genuine Galaxy S5.

Please assist me with upgarding this thing cause I have no idea what I'm doing. Thanks in advance.
 

ironass

Well-known member
Mar 9, 2015
5,189
498
83
Visit site
I bought a Galaxy S5 from a cellphone repair shop. I wanted to upgrade to 6.0 but when I went to Smart Switch it say my phone is up to date, OTA error says failed to communicate with server. Please try again.
Here is my details per Phone Info
1. Model# SM-G900T, android version 4.4.2
2. Latest Firmware= Not found, also #1234 # gives error= connection problem or invalid MMI code. PDA Version= G900MUBU1AUMS. CSC Version= G900MUUB1ANCE. Baseband Version=G900TUVU1ANCH. Product Code= SM2G900TZWAATT
3. Original CSC Code= ATT. Firmware's CSC Code= TTT. Active CSC Code= ATT/TTT. Availiable CSC Code= TTT
Device Type kltetmo. Product Name kltetmo.
4. Carrier Metro PCS. Country USA. Root Existence= No. Under Settings, About Device, Device Status= Custom
Details per Genuine Galaxy says Congradulations! It is a genuine Galaxy S5.

Please assist me with upgarding this thing cause I have no idea what I'm doing. Thanks in advance.

Hello and welcome to Android Central rb20100!

You have what I call a, "Hienz", phone, (57 different varieties). That is a phone that has been, "adapted", several times to work on different firmwares and networks. This is why it will never update OTA or via Samsung Switch, since it's model, Product and CSC codes do not match.

Thanks to the excellent information that you have provided, it would seem that you have the T-Mobile (USA) carrier model, G900T, that has had South American, G900M, firmware, possibly Trinidad and Tobago, flashed to it at some stage as well as AT&T carrier firmware.

Because of its chequered history I cannot be certain that it will accept this but you could try Factory Data Resetting the phone and flash the latest Metro-PCS stock Marshmallow firmware, see below, if that is your current carrier, to it by following the instructions and video contained in the links of #1.11 of 42 Galaxy S5 models - Dummies Guide

Model SM-G900T1
Model name GALAXY S5
Country USA (T-Mobile)
Version Android 6.0.1
Changelist 7500527
Build date Thu, 17 Nov 2016 05:04:16 +0000
Security Patch Level 2016-11-01
Product code TMB
PDA G900T1UVS1GPK3
CSC G900T1TMB1GPK3
 

TimCoahran

New member
May 21, 2020
1
0
0
Visit site
Hello and welcome to Android Central rb20100!
You have what I call a, "Hienz", phone...

Greetings, ironass!
I have the same problem as in this thread, and find your "42 Galaxy S5 models - Dummies Guide" extremely helpful. Since i may also be in over my head (like the previous user), i request your assessment and advice before i try anything.

Here's my real info:
Samsung Galaxy S5
Model SM-G900T
Android ver 4.4.2
PP: G900M UBU1A UMS
CP: G900T UVU1A NCH
CSC: G900M UUB1A NCE
Kernal ver: 3.4.0-964333
Build number: NCE-G900T-4.4.2-ACS-057514-1.0.0
SE for Android status: Enforcing, SEPF_SM-G900T_4.4.2_0055
Security software version: MDF v1.0 release 2, VPN v1.4 release 1


Here's what i THINK i could figure out, by following your previous post and guide:
This phone is another "Heinz-57"
Originally carrier branded T-Mobile, re carrier branded to ACS (see below),
Looks like in my firmware versions, the model#s don't agree with each other,
One of the versions is for South America,
My CSC must be UUB.

Known history:
I bought it from PROBABLY the original owner,
It probably is not rooted, and not have a custom ROM,
Probable first carrier was ACS- Alaska Communications Service (USA), it still displays their logo while booting,
I had a SIMM card put in, and first used it in Malaysia in 2017,
It now is with an Alaska carrier called GCI,
Several months ago it began failing to connect with secure websites, giving the error message SSL Certificates expired,
I have not succeeded in learning how to update certificates,
When i attempt to check-for-Android-updates, it says "Failed to communicate with server."
 

Members online

Forum statistics

Threads
943,084
Messages
6,917,188
Members
3,158,813
Latest member
pierre5463