Xiaomi RedmiS2 showing SIMcard memory total 0/1006 occupied, actual 205 contacts

xenh

New member
Jul 29, 2018
3
0
0
Visit site
I will try to be as short as possible, but also deliver the most details for a solution.

Xiaomi RedmiS2/global/4G/64GB
Android version 8.1.0 OPM1.171019.011
MIUI Version MIUI Global 9.6/stable 9.6.2.0 (OEFMIFD)

Current situation:
-inserted SIMcard has 205 contacts
-These 205 contacts are also showing up in S2 device, "local, on device only", and are working just fine.
-But at "show SIM memory" it says: total 0/1006 occupied, very odd...isnt it?
Functionality of the phone shows no problem...so far...
But:
1) at "import/export contacts" there is no option any more "copy/save/export contacts to SIM. Only option: "import from device > Create contact in account > local on device only > vCardFiles". It don’t say contacts. Is vCardFile the same as contact?***)
(The very first time I inserted the same SIM card, did "import/copy from SIM to device", and everything was fine. It showed me exactly: 205 local on device, 205 on SIM.)

2) At “export to device” > export contacts it says: "your list of contacts will be stored in file: /mnt/sdcard/00003.vcf"
At File Manager I cannot see such a file, where else are such files located?
And I don’t even have a SDcard inserted.

3) option "add/save new contact to SIM" is not showing up any more, only "to device".

What I tried so far:
-checked SIMcard on several other devices, it is OK and also new.
-changed SIM slots, cleared cache/system and did reset more than 10 times, also tried "flight mode", no result.
-inserted a total new and blank SIM card, the phone recognized the new SIM with new PIN, but at "show SIM memory" it still says: total 0/1006 occupied.

Further it shows at "configure your contact lists":
-FB-messenger: 0...which is odd, bcs. all messenger-contacts are there and working just fine. Cannot find out how many exactly, but not more than 280.
-Google/g-mail: 0...what is correct
-on device only, local: 205...what is also correct.
-total contacts: 205
Skype contacts are not showing up there, which are 18 (dont know if they should?)

That situation accured after deinstall of Viber-Dual-Apps. I had to deinstall bcs. “sticker-market-site” at GooglePlay blocked, won’t stop loading. Nothing helped, so I deinstalled both Apps. "Reset to factory" I did not, I dont know the consequences.

My request/settings:
On the S2 device I have/need no Google-(mail)-contacts, as it rightly shows "0", and I dont want to sync. My Skype-, FB-messenger- and Phone/SMS/Viber- contacts are 3 totally different lists, and I what them to stay so. Bcs. I need that SIMcard with the 205 contacts also for an other device.

edit:
***) I fortunately could, actual just by trying, restore my 205 contacts after deinstalling Viber-Dual-Apps using ''send all vCardFiles'' to "local, on device only". Bcs. Viber-contacts were/are exactly all my 205 phone contacts, and these contacts are working again just fine.

>>>What/how can/must I do to get rid of that crazy contact figures (total 0/1006 occupied) showing at "SIM memory", and get access again to my SIMcard contacts?

So far I reported my problem on several support sites...but not a single reaction...that mostly means no clue, right? :(
Thats why I thank you in advance for any answer, or please just give me a link where I can turn to.
My best regards.
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
1) at "import/export contacts" there is no option any more "copy/save/export contacts to SIM. Only option: "import from device > Create contact in account > local on device only > vCardFiles". It don’t say contacts. Is vCardFile the same as contact?***)
(The very first time I inserted the same SIM card, did "import/copy from SIM to device", and everything was fine. It showed me exactly: 205 local on device, 205 on SIM.)
So what's your problem? Your working contacts are now on your phone. (This is a change to keep all contacts on a Google account from now on.)

2) At “export to device” > export contacts it says: "your list of contacts will be stored in file: /mnt/sdcard/00003.vcf"
At File Manager I cannot see such a file, where else are such files located?
And I don’t even have a SDcard inserted.
/mnt/sdcard is the internal "sdcard". The file will be stored there - if you export it.

3) option "add/save new contact to SIM" is not showing up any more, only "to device".
No, you can only save a new contact to a Google account.

Further it shows at "configure your contact lists":
-FB-messenger: 0...which is odd, bcs. all messenger-contacts are there and working just fine. Cannot find out how many exactly, but not more than 280.
That's up to Facebook.

Skype contacts are not showing up there, which are 18 (dont know if they should?)
That's up to Skype.

My request/settings:
On the S2 device I have/need no Google-(mail)-contacts, as it rightly shows "0", and I dont want to sync.
Then, in Settings/Accounts/<your Google account>, turn off Contacts sync.

My Skype-, FB-messenger- and Phone/SMS/Viber- contacts are 3 totally different lists, and I what them to stay so. Bcs. I need that SIMcard with the 205 contacts also for an other device.
Any device you add the synced account to will sync the contacts on it. This is just integrating Android closer with Google - and preventing situations in which lost or damaged phones cause the user to lose hundreds (in one case here about 1500) contacts that were kept only on the phone.

>>>What/how can/must I do to get rid of that crazy contact figures (total 0/1006 occupied) showing at "SIM memory", and get access again to my SIMcard contacts?
No, the SIM is no longer used for Contacts. It was when the SIM was the only place on a cellphone that you could store things, but it should have been taken off as a contact storage place with the first smartphone. They finally got around to it.

So far I reported my problem on several support sites...but not a single reaction...that mostly means no clue, right? :(
No, it means that it's not a problem, it's a design change. And it's not going to be changed back. We now have internal storage and free cloud storage.
 

xenh

New member
Jul 29, 2018
3
0
0
Visit site
I thank you very much for your answer...you are the first, I really appreciate.
And I must point out that I do not question your qualification and knowledge, but please try to understand, that I do not understand. May be I am not a "qualified" user for Android-smart phones, bcs. I need/want a phone which is set up to my needs, and somehow also to my understanding and habits. And coming from BlackBerryOS I have quite a hard time with Android. No offence, I hope you can comprehend.

So what's your problem? Your working contacts are now on your phone. (This is a change to keep all contacts on a Google account from now on.)

My problem is that I cannot add/remove a contact to/from my SIM, and I need/want to do that. I need the SIM ready to go and up to date for the use in an other device. I dont want all contacts mixed and tangled up with Google(Accounts).

/mnt/sdcard is the internal "sdcard". The file will be stored there - if you export it.

ok, understood. And vCardFile in Android-language means contact?

No, you can only save a new contact to a Google account.

Sorry, but adding a new contact in the S2 there is a drop down menue, and one of the options is "to SIMcard". In my case its gone, of course, since the new "design" is funny, reading "SIM has 1006 contacts" already.

That's up to Facebook.

understood

That's up to Skype.

understood

Then, in Settings/Accounts/<your Google account>, turn off Contacts sync.

That was the first thing I did to prevent mixing up/link together my contact lists. I read and hear so much about these mostly unsolved troubles. No thanks!

Any device you add the synced account to will sync the contacts on it. This is just integrating Android closer with Google - and preventing situations in which lost or damaged phones cause the user to lose hundreds (in one case here about 1500) contacts that were kept only on the phone.

I prefer to have my contacts on a SIM, and always a SIMcopy, so my phone can sink to the bottom of the ocean, no problem for me and no need for Google, as long as the new "design" can read a SIMcard right. Add. I will never add more contacts than the SIM can store, what the "design" obviously can. Further, in general I am not "a friend" of Google, not at all. I have a g-mail account, compelled, but my Google-Account is "deserted". Too much "constraint", sorry, only to marry him Google didnt force me...yet, I think you understand where I come from. Again, no offence, but a "design" should fit the client, not the other way round....just saying.

No, the SIM is no longer used for Contacts. It was when the SIM was the only place on a cellphone that you could store things, but it should have been taken off as a contact storage place with the first smartphone. They finally got around to it.

Thanks God thats not the case for the Redmi S2, the device has still the options "show SIM memory" and "add contact to SIM". And these options were working just fine until the "GooglePlay-Viber-accident". And I rather have my contacts on a good old SIM in my pocket than somewhere in some "GoogleCloud", sorry. Call me ignorant, I dont mind.

No, it means that it's not a problem, it's a design change. And it's not going to be changed back. We now have internal storage and free cloud storage.

Sorry, the same "design" showed 205 contacts on SIM before the GooglePlay-accident, now it shows 1006 on the same SIM which is only able to store 250. How is that not a problem/bug? Probably the result of that "Google-tangling-all-together" ending up in multiply storing etc, quite understandable.

Ok, I note that there is no smart way to reset obvious wrong SIM memory reading, if I understood you right, or didnt I? So, my last option is to wipe everything from the S2 and give it a last try, before I crash my piggy bank for a BBKey2.
Sorry, it was my first try with Android, and I didnt expect such a disappointment. However, thank you for your time, I really appreciate.
 

xenh

New member
Jul 29, 2018
3
0
0
Visit site
EDIT:
Checked again your advice:

Then, in Settings/Accounts/<your Google account>, turn off Contacts sync.

Not possible on S2.
The only options are:
1)>Contacts > click to sync NOW....what I dont want
No option "turn off contacts sync"

2)> More > sync NOW..........what i dont want
>remove account...what I dont want
The only way I found is to: "block every interaction of contacts and contacts data".
And so far it seems to work. Google-Account shows 0 contacts.
 

Forum statistics

Threads
945,151
Messages
6,924,392
Members
3,159,678
Latest member
Cherylfallenangel