Z580CA Black screen with USB symbol... but hard reset not working!

Uzbecka

New member
Feb 9, 2017
4
0
0
Visit site
I have a Asus Zenpad S 8 (Z580CA) which is currently giving me nothing but a blank screen with the USB symbol in the middle. It happened after I restarted it after uninstalling/reinstalling the Mendeley app which was refusing to sync with the server (which it does on occasion).

When I do plug it in to my PC it isn't recognised.

Nothing happens when I hit the power button but even more worryingly the hard reset option does nothing too. That's pretty much the extent of my technical knowledge, and googling just tells me to hard reset.

So I'm stumped. Can't give any details about software versions in it's current state. Any advice will be most welcome :)
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,157
5,601
113
Visit site
Welcome to Android Central! Try pressing and holding Power for about 15 seconds. Does the screen change? If the screen turns off, then wait a few seconds, and try powering back on again. If the USB icon shows up again, then I would guess it's a hardware or firmware issue. The USB port or motherboard might be faulty, or the firmware could be corrupt. Is the device still under warranty?
 

Uzbecka

New member
Feb 9, 2017
4
0
0
Visit site
Welcome to Android Central! Try pressing and holding Power for about 15 seconds. Does the screen change? If the screen turns off, then wait a few seconds, and try powering back on again. If the USB icon shows up again, then I would guess it's a hardware or firmware issue. The USB port or motherboard might be faulty, or the firmware could be corrupt. Is the device still under warranty?

The screen goes off but when I press it again it goes straight to the usb symbol again. Don't get the asus logo or anything. Annoyingly its out of warranty by 20 days!
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,157
5,601
113
Visit site
What if you press and hold Power for about 15-20 seconds?

Inspect the microUSB port to make sure there isn't any debris in there, or that the pin isn't damaged.
 

Uzbecka

New member
Feb 9, 2017
4
0
0
Visit site
Nothing different happens with the power button.

There's no damage or debris in there but i just noticed that the bottom corner of the device casing creaks a little when i put pressure on it though where the port is. Leaning towards hardware issue? Its always been in a case so I've never noticed this before.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,157
5,601
113
Visit site
I think you're right -- it sounds like hardware. You'd have to bring it to a repair shop to find out for sure. Sorry!
 

Trending Posts

Forum statistics

Threads
945,915
Messages
6,927,686
Members
3,159,994
Latest member
yura32