1. E90 Commie's Avatar
    I have a very strange problem with my Thunderbolt that is connected to newer Gingerbread ROMs with Sense 3.0.

    The thing happens is that the SIM card is not detected by the device in those ROMs (Gingeritis 3D Beta VII, Synergy and Liquid Gingersense 1.6. I have run them with the MR2, MR2.75 and the leaked MR3 radio and different combinations without any success. I have also updated the CWM to the modded from and completely wiped /system, /data and Dalvik cache between every flash.

    When I flash an older Gingerbread like Gingeritis 1.2, the SIM card is detected again and contacts stored there show up. But immediately when a new Sense 3.0 ROM is flashed, it simply disappears which also removes the 4G connection of obvious reasons. The result of that is a complete loss of all data connection. It's possible to get 1X with the cover off (removal of the 4G antenna) but immediately when the cover is put back, all connection (including 1X and 3G) disappears.

    All problems seems to be related to some kind of compatibility problem between the SIM card and the newer ROMs. My Thunderbolt is one of the first out there and it runs the first "Easy root" method that was released.

    Beside this strange problem with the SIM card and the associated loss of data connection, it works perfect.

    It would be interesting if there are any suggestions. I have double checked all MD5 checksums to be sure that all ROMs has been downloaded properly.

    I am grateful for help with this issue. I would prefer to run the latest Sense 3.0 ROMs with working 4G.
    08-10-2011 02:49 PM
  2. ssethv's Avatar
    Very strange indeed... I am kinda stummped myself... maybe a dumb question, but how did you flash the newer radios? in HBOOT right?
    08-10-2011 04:29 PM
  3. E90 Commie's Avatar
    I have now made some additional experiments including flashing the device without the SIM inserted. That removes all abilities to make calls, obviously.

    When the SIM is reinserted, it found the network with a strong signal and calling works. I have now also noticed that saving contacts to the SIM works and the People app can show them properly. The only place where the problem shows up is under Wireless and Networks under the APN settings. When I enter that part, it says "no SIM found". Otherwise the card is obviously found by the device and calls are working. Data connection is not working though, it's only if I remove the battery cover that I can manage to get 1X working. So there seems to be something going on with the SIM in the 4G department.

    My experimenting indicates that the SIM is working otherwise. When I tried other ROMs I have now noticed that the 4G is missing, it can't connect on 4G at all. The difference is that "SIM card not found" under APN settings is not shown.

    Status for now with other words:

    1. Phone calls works.
    2. Saving and managing contacts to and on the SIM works.
    3. APN settings presents the "no SIM card found" message. The APN itself shows up.
    4. Data connection is not working with the battery cover on.
    5. With the battery cover off, I receive 1X.

    I have also tried to set it on CDMA (auto PRL) without any success when it comes to data connection with the battery cover on.
    08-10-2011 07:52 PM
  4. ssethv's Avatar
    Have you flashed any radio's at all through HBOOT (placing the image PG05IMG.zip on the ROOT of your sd card and when the phone is off, hold down the volume down button and power button at the same time. this takes you into hboot, will then automatically recognize the radio and just follow the directions. Im just asking if you have ever done this before.... I just want a starting point to work from

    also, you havent' ever tried the old dial 228 trick right? cuz that will def mess your phone up...
    08-10-2011 08:31 PM
  5. E90 Commie's Avatar
    I have flashed the radios through Hboot according to the procedure you have described. The 228 trick has never been used. The only code I have entered is the *#*#7664*#*# in an attempt to restore connection through 3G atleast.

    The interesting thing is the fact that the SIM card itself is recognized for phone book and calls. It's only the data connection that fails paired with the strange error message under APN settings (this applies to the Synergy ROM, latest nightly).

    WiFi is working perfectly and I can make phone calls (have tried).

    Edit: When I entered *#*#7664*#*# the problem was already started, I did that in a last resort attempt after finding it in a different thread on connection problems.

    All radio flashing has been made through Hboot with PG05IMG.zips.
    08-10-2011 08:46 PM
  6. ssethv's Avatar
    I am at a loss. sounds like a sim card issue (they can go bad).
    08-10-2011 09:02 PM
  7. mzm's Avatar
    I had this same problem a couple weeks back where 4g just stopped working one day after i flashed a certain ROM. For me, 3g seemed to be fine as long as I had it set to cdma auto (PRL) only, otherwise when it was set on the cdma+lte/evdo auto the phone had problems keeping a connection. I tried everything from restoring to flashing different ROM's to flashing all the different radios with no luck. I'm no expert, so eventually i thought well let me see if the phone works properly if i unroot... it didn't. It still wouldn't connect to 4g.

    Finally decided that I would take it into Verizon and see if they could help me out. Funny thing was, once I walked near this specific Verizon, phone connected to 4g. WTF rite? I mess around with the phone for a bit and it seems to work fine. I decide to test it out by leaving the parking lot and driving around for a bit around town. 4g drops and doesn't pick up anywhere I go. I decided to go back and complain to them and attempt to convince them that my 4g isn't working even though it was clearly working in their store and anywhere near them. I just told them it was a joke if I had to come to their store to use my 4g. Basicly i just complained long enough for them to give me a replacement.

    Long story short, I'm not sure if its the SIM cards problem. I say this because i thought it could be something with the SIM card and asked them if we could try a new one in my old phone which they said no to and that it wouldn't do anything. When I received the replacement, I put my original SIM card in the new phone, booted it up and 4g connected right off the bat. It's been about a week now and 4g seems to be fine. I just rooted the other night but haven't gotten to any flashing yet. I'm quite happy with this replacement phone... everything seems to be working fine and it looks brand new. Hope this helps...
    08-11-2011 04:54 PM
  8. DaRkL3AD3R's Avatar
    Huh... that's an odd story there mzm.

    I was having serious radio issues mostly data dropouts after updating to chingy's radio 2.xx.xxxx and a lot of people on rootzwiki told me it was a dead SIM. So I took my baby into a VZW store, asked them to replace my SIM cards, and ever since my data connection has been rock solid.

    But I am confused. You say you got a replacement phone, but used your old SIM, and it worked fine? Man I hope its not just my phone thats dead, and it really was the SIM. I hate these stupid SIM cards. I miss the old *228
    08-12-2011 10:46 PM
  9. Andrew Ruffolo's Avatar
    my phone doesn't activate when I flash roms based off of the newest gingerbread leak. What I do when that happens is turn off the phone, pull battery and sim for 2 minutes and put it back in and voila, im all set to go. No need to reflash rom as it would just happen again.
    08-14-2011 12:25 AM