1. jedininjafication's Avatar
    Ok so here's the scoop. I'm a total whiz on rooting Samsung devices. Chic asked me to helpher with a thunderbolt she bought from craigslist. Turns out it doesn't have the radio file on it so won't connect and since it's rooted Verizon can't do anything. Props because they did try for a few hours. Anyway..I did some research and downloaded a radio..guessing it wasn't the correct one because it did some s-on security warning thing. I messed with this thing and messed with this thing and have NO CLUE how i finally removed the security warning. Tried the ruu things and they would shut the phone down. Anyway, got past that crap. On the pg05img.zip update it FINALLY moves past the older version garbage and allows me to start the update. So i thought! The phone powers off at the splash screen part of the update every single time. Went to htcdev to try to unlock bootloader. Let's me get all the way to the end but won't power down and reboot once i select yes. I've tried the adb as far as my knowledge allows for..dude..i started learning root on the nexus s4g and have since moved on to the galaxy nexus..hands me a Samsung and I'll have it unlocked, rooted with custom recovery, and flashed in blink of an eye. I'm at a total loss when it comes to this htc thunderbolt pile of electronic headache! Props to you thunderbolt devs! You guys are geniuses! Anyway.. I now have security warning gone with s-off still enabled. Can't unlock bootloader. Ruu says can't access device in windows. This phone didn't come with a memory card so i wiped one of my other Samsung cards to install files on. Recovery has the red triangle. I REFUSE to get beat by a phone and am not a noob to root, just HTC. Any help would be greatly appreciated. Have scoured all forums and it seems there is always one tiny part that doesn't apply to my situation. Thanks in advance.
    06-01-2012 01:30 AM
  2. jedininjafication's Avatar
    It's s-on. Sorry if this is considered overpost as i posted in different section and was told might be better here.
    06-01-2012 01:32 AM
  3. a22shady's Avatar
    well I am not sure about your situation. I klnow that you need an SD card though to install Customs Rom's, Or Roms, and radio's from. Everything gets installed from the phone not the computer. If you want a factorry stock Root Rom there is links here. And its quite simple. If all you want is a radio installed All you have to is is drag and drop the radio file onto the root od the sd card in other words do not put it in any folder. Than Power off the device completly and then Power it on while holding down the volume button. It will load up the boot screen. After couple seconds push down on volume key. It will say located Radio would you like to update select yes and it will unzip and update the radio.

    Here is a step by step guide with pics how to install ROms/radios everything for the Tbolt

    http://forums.androidcentral.com/thu...underbolt.html

    Here is a link to the 2.11.605.9 radio
    PG05IMG.zip

    There is a newer radio out the .19 but for me it seems to give worse reception and make my phone staticky

    Here is a link to the new 2.11.605.19 ROM

    http://rootzwiki.com/topic/23371-sto...-21160519-rom/
    jedininjafication likes this.
    06-01-2012 06:38 AM
  4. z71kris's Avatar
    try flashing the 2.11.605.19 posted above and report back.
    jedininjafication likes this.
    06-01-2012 07:53 AM
  5. jedininjafication's Avatar
    The ROM listed above says to flash in cwm. There is no recovery on phone, custom or otherwise. Can i just rename it to the pg05img.zip and try that way? Tried to do the ruu thing while hooked to computer and that powers the phone down. Did a differentzip and it started the update but shut the phone down when reached the splash screen part so now won't boot past the HTC screen. At least I've gotten it out of the hboot security warning..that was a core and i have no idea how i did that! Honestly, i believe it's going to have to be a stock ROM because it won't let me unlock the bootloader. Like said, gets all the way to the very end where i would select "yes" but will only reboot if i select "no". when i finally get this thing going I'm never touching an HTC again! I'll stick with simple Google devices lol
    06-01-2012 09:19 PM
  6. jedininjafication's Avatar
    Oh, i totally forgot..when chick first purchased phone from craigslist..i noticed there wasn't an esn stored within the phone. Don't really understand that part of it because the serial willcome up when i do adb devices command. Could that be why it powers down on the update and can't unlock bootloader?
    06-01-2012 09:25 PM
  7. z71kris's Avatar
    Have you tried flashing cwr?

    sent from my Thundershed Thunderbolt
    jedininjafication likes this.
    06-02-2012 07:59 AM
  8. jedininjafication's Avatar
    Doesn't the bootloader have to be unlocked to flash a recovery? I know that's the first thing i have had to do on any phone i have rooted. does HTC not have a program like Odin that i can extract the pit file from? Like i said, I'm a die hard Samsung fan and have always had the Google devices. They basically encourage you to unlock them..so easy. This is my first non Samsung device I've played with and the isn't even mine. Was just trying to help someone get their phone working. Had become a nightmare! I mean, it's in somewhat of a better state than when first started on it but man..I'm tellin ya! It's become my personal mission and I've declared war on this phone!
    06-02-2012 09:26 AM
  9. dizzyrickyb's Avatar
    Yes, you need to be s-off to flash the recovery. In the root section, it explains how to use revolutionary method to root and s-off. Once it says revolutionary at the top on the bootloader menu, then you can try and flash cwm. From there you can put a custom Rom on the phone.

    Sent from my ADR6400L using Android Central Forums
    jedininjafication likes this.
    06-02-2012 04:12 PM
  10. jedininjafication's Avatar
    Ok so...I made SOME progress. Almost thought i had it dang it! Again.. I have no clue what or how i got this far BUT I did almost get the ruu to update via usb. Totally thoughtI had it. Was pretty much finished with the update when it said something like incorrect bootloader please use correct update utility..?!?! Grrrr, bout ready to set this thing on FIRE. But can't. Because there hasn't been an electric made that has beat me. once again, I throw myself at your feet and ask which one should I use? The info under bootloader is:
    mecha xd ship s-on hboot- 1.05.0000 microp-/ radio-1.16.00.0402w_1 emmc-boot July 19 2011, 14:51:08
    Thank you again.


    Sent from my Sprint Galaxy Nexus CDMA using Android Central Forums
    06-06-2012 11:48 PM
  11. jedininjafication's Avatar
    And revolutionary just keeps waiting for device. Nada.

    Sent from my Sprint Galaxy Nexus CDMA using Android Central Forums
    06-07-2012 12:06 AM
  12. dizzyrickyb's Avatar
    Ok...I had same issue w/revolutionary not seeing device. Try reinstalling device drivers and it should work. Go to revolutionary site and they should have them.
    If you can't find it there is a link in this thread
    http://forum.xda-developers.com/showthread.php?p=27078714
    See if that works, once you get s-off then you can RUU if needed.



    my ADR6400L using Android Central Forums
    jedininjafication likes this.
    06-07-2012 11:51 AM
  13. jedininjafication's Avatar
    DO YOU HEAR THAT..? SSSHHH...LISTEN..THAT BE THE SOUND OF THUNDER!!If it's alright I'm going to post a link to Android Forums in case anyone else has this issue. Five minutes and I was DONE! I tried to register there to give profound thanks to the dude that posted this, but after about my 6th attemp at the captcha (however spelled) and no dice I just have to hope he one days happens upon this post.
    THANK YOU everyone for the input and direction arond the forums. I think I'm pretty much signed up in all of them now! Now I can go back to flashing my phone and having fun like root is supposed to be! Again...thanks all!
    http://androidforums.com/thunderbolt...img-files.html
    06-07-2012 02:36 PM
  14. jedininjafication's Avatar
    oh, how do I mark this as solved? just edit the title or is there a tab or something?
    06-07-2012 02:39 PM
  15. dizzyrickyb's Avatar
    Awesome. Glad you got it all worked out my friend. Oh and excellent name btw

    Sent from my ADR6400L using Android Central Forums
    06-10-2012 10:43 PM
  16. jedininjafication's Avatar
    Well, I'm gonna have to say it was my Jedi mind powers along with my stealthy ninja skills that got me thru this..well that and everyone trying to help lol.

    Sent from my Sprint Galaxy Nexus CDMA using Android Central Forums
    06-10-2012 11:10 PM
  17. z71kris's Avatar
    good deal
    06-11-2012 07:48 AM
LINK TO POST COPIED TO CLIPBOARD