1. SpaceHippie's Avatar
    Ok this is really becoming a problem. Im not a noob to rooting but im definitely stuck here. Im on a macbook pro. My previous phone was an htc incredible. I rooted that phone a few times on this same computer and suddenly it wouldn't work anymore. When i stared unrevoked, it would never recognize my phone. I thought oh my phone must have issues, but now im on my Thunderbolt and it's the same deal. I tried the root method from cory but when i run terminal, my phone never shows up. Ive done the obvious, enabled usb debugging, put the phone as a disk drive etc. Still no dice. My phone shows up on the computer, i can transfer data and such but when it comes to rooting, i hit a wall. What should i do? It's obvious the issue is with my mac, but the drive works fine. Any suggestions from the pros?
    03-28-2011 03:09 PM
  2. cfairchi's Avatar
    May be a stupid question, but have you rebooted your computer? I was having all kinds of problems with mine until I rebooted. Of course it is a win 7 box not a mac

    Sent from my ADR6400L using Tapatalk
    03-28-2011 07:48 PM
  3. sicario666's Avatar
    Is usb debugging enabled? You need to have it enabled

    Tbolt meatclaws via talkatap
    03-28-2011 08:14 PM
  4. dkoss's Avatar
    Does ADB have proper permissions. What is it saying when you type ./adb devices?
    03-28-2011 08:57 PM
  5. SpaceHippie's Avatar
    Yes i have it debugged, yes i rebooted my mac. And when i type in ./adb devices, it doesn't show anything. It doesn't show anything connected. But my usb drives are fine because i connect my bolt often to sync music with doubletwist and to load photos.
    03-29-2011 12:17 AM
  6. Cory Streater's Avatar
    Ok this is really becoming a problem. Im not a noob to rooting but im definitely stuck here. Im on a macbook pro. My previous phone was an htc incredible. I rooted that phone a few times on this same computer and suddenly it wouldn't work anymore. When i stared unrevoked, it would never recognize my phone. I thought oh my phone must have issues, but now im on my Thunderbolt and it's the same deal. I tried the root method from cory but when i run terminal, my phone never shows up. Ive done the obvious, enabled usb debugging, put the phone as a disk drive etc. Still no dice. My phone shows up on the computer, i can transfer data and such but when it comes to rooting, i hit a wall. What should i do? It's obvious the issue is with my mac, but the drive works fine. Any suggestions from the pros?
    Hmmmm. The main things are:

    1.) USB debugging on -- you've done this.
    2.) Selecting disk after plugging it in -- you've also done this.

    So, are you using the SDK that I posted or a different one? Also, which cable are using? The one that came with the TB or your Incredible cable?

    P.S. can you post the last several lines of your terminal window?
    03-29-2011 12:32 AM
  7. SpaceHippie's Avatar
    Yep debugging is enabled.
    Disk is selected.
    Im using my cable from the TB packaging. Ive also tried several other cables. This is my terminal window.

    Last login: Mon Mar 28 11:58:47 on ttys000
    djs-mac:~ DeJonne$ cd ..
    djs-mac:Users DeJonne$ cd ..
    djs-mac:/ DeJonne$ cd and*
    djs-mac:android-sdk-mac_x86 DeJonne$ cd tools
    djs-mac:tools DeJonne$ ./adb devices
    List of devices attached

    djs-mac:tools DeJonne$


    Nothings showing. I figure it's the same issue as i had with my incredible because when i tried to use unrevoked it wouldn't recognize my phone. But ive rooted before on this mac using unrevoked. Several times.
    03-29-2011 01:58 AM
  8. SpaceHippie's Avatar
    bump
    03-29-2011 10:41 PM
  9. PX9023's Avatar
    I've been trying for days to get this root working and I have run into the same problem as you. I am not new to rooting. I have tried every possible method, and have had no luck... I even tried the easy root for mac... But the terminal just keeps searching for the phone and has no success. It is honestly starting to drive me insane... About to give up... If you figure it out please let me know...

    Tbolt-- really bloated
    04-10-2011 03:51 AM
  10. rsk2mc's Avatar
    Are you running the newest version of snow leapord on your Mac? Your phone won't work because Mac defaults to 64 bit on start up however if you reboot holding; I'm not sure ; f7 it gives you the option to boot 32 bit. I'm not sure what key it is so look it up ; but that should fix the issue
    04-10-2011 09:06 AM
LINK TO POST COPIED TO CLIPBOARD