1. voigts's Avatar
    I just got my Charge and am trying to get it to connect to my network at home. I am using WPA2 PSK on my router. The phone sees the SSD of the network, correctly identifies the WPA2, but when I put in my network key and hit connect, I get a box that pops up and says "unable to save network," and it won't connect. I copied and pasted the key into the phone via email to make sure the key is correct. I've Googled and Googled and can't find anything on this problem.

    I'm rooted running stock EE4.
    07-25-2011 04:33 PM
  2. geochemical's Avatar
    Is there a chance that you are using MAC address filtering on your router in addition to a network key? In that case you will have to add your phone's MAC to the router's filter list. The MAC address is displayed on Settings/Wireless & network/Wi-Fi settings/Advanced
    07-25-2011 11:23 PM
  3. voigts's Avatar
    I'm not using any kind of MAC filtering. I'm stumped because I simply can't find anything on why this is happening.
    07-26-2011 11:47 AM
  4. kadiir's Avatar
    Does it work if you try set your router to WEP or even open? If so, then it's something with WPA2 PSK that either the router or phone doesn't like.
    07-26-2011 07:21 PM
  5. voigts's Avatar
    I haven't tried that with my router yet. I was in a hotel when I first got it a couple of weeks ago, and it connected there to an open router with no problem. I'll have to switch my router and see what it does.
    07-27-2011 06:59 PM
LINK TO POST COPIED TO CLIPBOARD