1. swenpro's Avatar
    Every time I plug my Charge into my computer via USB, it automatically mounts the SD card for transferring files. Is there a way to turn this off?

    I did try USB settings --> Ask on Connection, but every time I reenable USB debugging, that setting reverts to USB settings --> Mass Storage.
    07-27-2011 10:42 PM
  2. MNorby's Avatar
    Have to turn off auto mass media setting. I had same problem with one of my chargers
    07-27-2011 10:51 PM
  3. swenpro's Avatar
    Have to turn off auto mass media setting. I had same problem with one of my chargers
    Can you please explain more with exact menu names? As I wrote, I tried changing USB Settings to something other than "Mass Storage", but when I re-enable USB Debugging in Applications --> Development (for internet tethering), the USB Settings reverts back to "Mass Storage".
    07-27-2011 11:41 PM
  4. geochemical's Avatar
    Assuming you are using Windows 7, when the Autoplay explorer window pops up for your Charge's SD card, select "View more Autoplay options" and change the behavior to what you want.
    07-27-2011 11:57 PM
  5. Rudolphe's Avatar
    Every time I plug my Charge into my computer via USB, it automatically mounts the SD card for transferring files. Is there a way to turn this off?

    I did try USB settings --> Ask on Connection, but every time I reenable USB debugging, that setting reverts to USB settings --> Mass Storage.
    I'm pretty sure you can't do anything about this. When you enable usb debugging it arbitrarily enables mass storage on connect.

    There might be an app or something that can help but by default this is the way it's designed.
    07-28-2011 10:42 AM
  6. swenpro's Avatar
    I'm pretty sure you can't do anything about this. When you enable usb debugging it arbitrarily enables mass storage on connect.

    There might be an app or something that can help but by default this is the way it's designed.
    Interesting. This didn't seem to be the case on my Fascinate. A minor inconvenience I guess, having to 'Stop' the Mass Storage from the drop-down menu every time I unplug from my computer, when I wasn't using that feature anyway...
    07-28-2011 10:48 AM
  7. rmanaka's Avatar
    The only way to stop this from happening is to fabricate a "charge only" cable. Simply cutting or disconnecting the data wires (usually green and white) won't work... you have to short the data wires together. Now CAUTION, this will allow the cable to charge at the same rate as if it was connected to the wall charger and will drain a laptop battery pretty quickly... it works great with a high amperage USB cigarette charger, however!

    ps. Short the data pair going TO the phone, NOT the pair coming FROM the computer!
    Sent from my SCH-I510 using Tapatalk
    07-28-2011 10:24 PM
  8. imapepper2#AC's Avatar
    I also thought it was annoying that every time I plugged my Charge into a charger at home or at work the mass storage function stopped whatever I was doing.

    The best option for me was to use the USB settings --> Media player.
    07-29-2011 10:38 AM
LINK TO POST COPIED TO CLIPBOARD