1. whit3fang's Avatar
    My wife just got a samsung droid charge two weeks ago. worked fine for awhile. now when she turns it on, she doesn't have 3g connectivity. when she tries to use the brower, market etc. nothing happens. just get a message that there's no connection. Verizon replaced the sim card but still have the problem. when she has no 3g showing on her phone, she can call out and get calls in. when 3g is showing, forget it.... nothing in or out. anyone have any suggestions? if so, please explain in plain english....we're not tech savvy. Thanks.
    07-29-2011 11:53 PM
  2. Moscow Desire's Avatar
    You could be on the edge of the coverage area (don't belive what their coverage maps tell you)

    First off, I would go into the Settings, and check the Mobile Network settings. Make sure you have Data Enabled. If you have Use only 2g Networks enabled, uncheck it.

    If you don't find anything unusual in the Network settings,,,,,,,

    Do a synch of your contacts.sms, etc either to Gmail or your PC. Then do a factory reset. Note that you will lose all info stored on the internal phone memory, and you'll have to go through the process again, just like a new phone. I like to synch to my pc, as it gives me the chance to edit things easily.

    If this doesn't work any better, well, it could be a bad phone or bad coverage issue.
    07-30-2011 02:12 AM
  3. mamawM's Avatar
    it would probably help to ask this question over in the charge forums. the 4g phones do seem to have some issues when trying to decide whether to lock in on 3g or 4g signals and thus don't lock in on either one. going into settings and setting the phone to cdma only usually fixes this problem but you lose the blazing fast 4g.
    07-30-2011 08:16 AM
  4. Cory Streater's Avatar
    Great answers. Keep us posted whit3fang. If your 14 day isn't up, I wouldn't rule out an exchange either. You may have just gotten a lemon. After 14 days they start sending out refurbs, which isn't bad I guess, but it is kind of annoying.
    07-30-2011 08:53 AM
  5. papa54's Avatar
    Great answers. Keep us posted whit3fang. If your 14 day isn't up, I wouldn't rule out an exchange either. You may have just gotten a lemon. After 14 days they start sending out refurbs, which isn't bad I guess, but it is kind of annoying.
    my charge shows nothing, no 3g 4g or any bars but when i want to download anything the 3g lights up.. as soon as that business is over. the 3g goes grey, and no bars again.it works great on DL apps with out use of my wifi... with wifi or without its fairly fast..i do notice a lag on the charge but over all its twice the phone my fascinate was...
    08-02-2011 12:35 AM
  6. piizzadude's Avatar
    Are you in a 4G area? if not you might want to just switch it to permanent 3G and see if that helps the cause
    08-02-2011 12:56 AM
  7. qgqlewis#AC's Avatar
    I had the same issue. I talked with several verizon techs and tweaked every setting known to man. They finally came to the conclusion that it was a bad sim card. After 2 days of no data it just suddenly came back out of the blue. I have received a new sim card but i haven't put it in yet. This seems to be a common problem with the phone. From what I have been reading there is supposed to be a fix with gingerbread. I just hope it doesn't happen again. 2 days without data was brutal!
    08-02-2011 03:23 AM
  8. barrycinti's Avatar
    I had the same issue. I talked with several verizon techs and tweaked every setting known to man. They finally came to the conclusion that it was a bad sim card. After 2 days of no data it just suddenly came back out of the blue. I have received a new sim card but i haven't put it in yet. This seems to be a common problem with the phone. From what I have been reading there is supposed to be a fix with gingerbread. I just hope it doesn't happen again. 2 days without data was brutal!
    I was recently out of town on vacation and had no issues with my Charge. At home I have several issues.
    1. bad data connectivity
    2. dropped calls
    3. garbled calls
    4. fast battery drain.

    For those having issues you may want to check the following.
    - about phone - status - check the signal level, if it is -102 or worse youwill probably have issues.
    YMMV
    08-02-2011 10:47 AM
  9. putney1477's Avatar
    My signal is -76...that can't be good. I have big time connectivity issues lots of times I have no connection at all. I am going to Verizon today. See if its the similar card or what.

    Sent from my SCH-I510 using Tapatalk
    08-02-2011 10:59 AM
  10. qgqlewis#AC's Avatar
    I was recently out of town on vacation and had no issues with my Charge. At home I have several issues.
    1. bad data connectivity
    2. dropped calls
    3. garbled calls
    4. fast battery drain.

    For those having issues you may want to check the following.
    - about phone - status - check the signal level, if it is -102 or worse youwill probably have issues.
    YMMV
    You obviously haven't had the actual issue that is being talked about here. Let me explain. No data, none at all. it is as if verizon turns off your data completely....its just off. I don't care what setting change you do, how much signal you have, or factory resets, or dance around your phone naked with a dead chicken..... your data is just off....gone....not a signal factor....not talking about dropped calls or battery drain....the issue is just no data. there is however phone service. just no data. the data just comes back whenever your phone allows it.
    08-02-2011 02:11 PM
  11. Heath276's Avatar
    You obviously haven't had the actual issue that is being talked about here. Let me explain. No data, none at all. it is as if verizon turns off your data completely....its just off. I don't care what setting change you do, how much signal you have, or factory resets, or dance around your phone naked with a dead chicken..... your data is just off....gone....not a signal factor....not talking about dropped calls or battery drain....the issue is just no data. there is however phone service. just no data. the data just comes back whenever your phone allows it.
    Mine is doing the same I'm on 3g running good and BAM it gone only way to get it back is restart my phone so I don't have as bad as u do but it sucks and nope dancing around it naked with a dead chicken does nothing witch saddeneds me.

    Sent from my SCH-I510 using Tapatalk
    08-04-2011 08:32 AM
  12. whit3fang's Avatar
    Thanks to all who replied. Went back and they switched out the sim card in her phone and everything worked ok. When we left the store, it went right back to what is was doing before. Got home and did some searching and found someone who who the samsung charge who had about the same issues my wife was having and they said it was juicedefender. I unistalled that from her phone and she hasn't had any issues since. Thanks again for the replies.....
    08-15-2011 01:12 AM
  13. barrycinti's Avatar
    Thanks to all who replied. Went back and they switched out the sim card in her phone and everything worked ok. When we left the store, it went right back to what is was doing before. Got home and did some searching and found someone who who the samsung charge who had about the same issues my wife was having and they said it was juicedefender. I unistalled that from her phone and she hasn't had any issues since. Thanks again for the replies.....
    I'm having the same problem. I have never had juice defender cdma only makes no difference. Ideas? Thx
    08-15-2011 10:28 PM
  14. PreceptorJR's Avatar
    My data connection drops out all of the time - 3G or 4G...we need a software update for this badly.

    Are there any other apps that could cause this problem? The only one I can think of that I might have on my phone is Elixir.
    08-16-2011 10:00 AM
  15. barrycinti's Avatar
    My data connection drops out all of the time - 3G or 4G...we need a software update for this badly.

    Are there any other apps that could cause this problem? The only one I can think of that I might have on my phone is Elixir.
    Long story short. Had vz store replace the sim card. All is well now. I hope this is a permanent fix.
    08-16-2011 03:10 PM
  16. Landshark's Avatar
    My signal is -76...that can't be good. I have big time connectivity issues lots of times I have no connection at all. I am going to Verizon today. See if its the similar card or what.

    Sent from my SCH-I510 using Tapatalk
    -76 is actually a good score. Basically it works in reverse. The lower the number, the better your signal strength.
    08-16-2011 10:44 PM
  17. MP5_ForTheWin's Avatar
    I just had the issue today where the 3g icon disappears permanently, before it has disappeared but would come back after a reboot not anymore.. Took it by a store and they swapped out the SIM all is well now... I and the store tried everything before swapping the SIM... rebooted the phone turned off the radios rebooted etc... and no avail. I had 5 bars of signal and could make and receive calls fine just no data. WiFi works fine.

    They swapped the SIM out and now the 3g icon sticks around all the time, before when I had WiFi enabled it wouldn't show... which is interesting... To you guys does the 3g icon stick around after you connect to WiFi? On my Palm Pre it would be replaced with the WiFi icon and I assumed that was supposed to happen with the Charge, but apparently not?

    Thanks
    08-19-2011 05:54 PM
  18. papa54's Avatar
    You obviously haven't had the actual issue that is being talked about here. Let me explain. No data, none at all. it is as if verizon turns off your data completely....its just off. I don't care what setting change you do, how much signal you have, or factory resets, or dance around your phone naked with a dead chicken..... your data is just off....gone....not a signal factor....not talking about dropped calls or battery drain....the issue is just no data. there is however phone service. just no data. the data just comes back whenever your phone allows it.
    my signal is -107 to -113 back n forth.. prl vs. 15027.
    running stock.. i tried the rooted roms but my Charge works better unrooted..
    the whys how comes i have no answers to, but my charge so far has not failed me,
    except the black outs when i call my voice mail the screen blacks out as soon as my fingers get close to the buttons to push a number but signal is by far better than anything tha fascinate would do..
    i was so glad that thing fell into the stingray tank at aquarium..
    then got this charge...
    08-21-2011 01:01 AM
  19. papa54's Avatar
    I just had the issue today where the 3g icon disappears permanently, before it has disappeared but would come back after a reboot not anymore.. Took it by a store and they swapped out the SIM all is well now... I and the store tried everything before swapping the SIM... rebooted the phone turned off the radios rebooted etc... and no avail. I had 5 bars of signal and could make and receive calls fine just no data. WiFi works fine.

    They swapped the SIM out and now the 3g icon sticks around all the time, before when I had WiFi enabled it wouldn't show... which is interesting... To you guys does the 3g icon stick around after you connect to WiFi? On my Palm Pre it would be replaced with the WiFi icon and I assumed that was supposed to happen with the Charge, but apparently not?

    Thanks
    my 3g comes on when i cut wifi off... and the darned thing usuall loads faster with the 3g than with the wifi.. sometimes i use the wifi but thus far i love the charge..
    08-21-2011 01:04 AM
  20. onlyoneromeo's Avatar
    No data = sim card. Exchange it. Same thing was happening w my thunderbolt. New card no problems.
    08-21-2011 08:31 AM
  21. PreceptorJR's Avatar
    My data connection drops out all of the time - 3G or 4G...we need a software update for this badly.

    Are there any other apps that could cause this problem? The only one I can think of that I might have on my phone is Elixir.


    I took Elixir off my phone 3 days ago, and I haven't noticed any data drops since then.
    08-21-2011 11:06 AM
LINK TO POST COPIED TO CLIPBOARD