1. pauldroidr2d2's Avatar
    Has anyone else had problems with the bluetooth randomly disconnecting from a paired handsfree device? Mine does this occasionally and sometimes I have to reset the phone twice before it recognizes it again.
    08-06-2011 02:50 PM
  2. 04redgto's Avatar
    I get this as well, then have to go into settings n reconnect. Very annoying!
    pauldroidr2d2 likes this.
    08-06-2011 07:27 PM
  3. pauldroidr2d2's Avatar
    I get this as well, then have to go into settings n reconnect. Very annoying!
    It is very annoying.

    Sent from my SCH-I510 using Tapatalk
    08-09-2011 05:45 AM
  4. dhp106's Avatar
    It is very annoying.

    Sent from my SCH-I510 using Tapatalk
    Sometimes my stereo takes a while to connect to the bluetooth. Most of the time it will connect right away to the handsfree but take like 5-10 minutes to connect to stereo for music. Sometimes it doesnt connect at all so i have to manually connect it.
    08-09-2011 11:20 AM
  5. sv_one's Avatar
    Yes, same here...

    Anyone have any ideas on a fix?
    08-09-2011 11:24 AM
  6. Streamheat's Avatar
    Sometimes my stereo takes a while to connect to the bluetooth. Most of the time it will connect right away to the handsfree but take like 5-10 minutes to connect to stereo for music. Sometimes it doesnt connect at all so i have to manually connect it.
    I turn my other paired device (Bluetooth headset) off before I turn my car on. Seems to work.
    08-09-2011 12:06 PM
  7. atlantar6's Avatar
    Yep, and it's only fairly recent. If I press the bluetooth button on and off on the phone while on a call it comes right back.
    08-09-2011 04:32 PM
  8. richardpandy's Avatar
    My bluetooth is terrible. Sometimes it connects, sometimes it doesn't connect and its not just with one thing. I have an Jawbone Icon in my truck as well as a motorola s9hd headphones and I have a jawbone era in my work truck. Every single one of them has problems connecting to my phone. They all connect properly to my POS LG Dare work phone but rarely to my charge. Another thing is once it does connect, sometimes people can't hear me but I can hear them. It's super annoying.
    08-09-2011 07:59 PM
  9. 04redgto's Avatar
    If you go into running services, and stop bluetoothpbapservice it helps greatlly from what I have found.
    08-09-2011 10:44 PM
  10. sv_one's Avatar
    Yep, and it's only fairly recent. If I press the bluetooth button on and off on the phone while on a call it comes right back.
    Exactly. Fairly recent & this does help it work.

    Odd.
    08-09-2011 11:45 PM
  11. 04redgto's Avatar
    Exactly. Fairly recent & this does help it work.

    Odd.
    Did u see my post above yours? I stopped that service 3 days ago, and Bluetooth has been perfect ever since.
    08-10-2011 09:18 PM
  12. ick's Avatar
    It definitely seems counter-intuitive but stopping the BluetoothPbapService has been the solution for me as well. I couldn't get the bluetooth module in my car to upload my phones contact list or keep the bluetooth connected until I stopped this "service". Just remember that if you shut the bluetooth connection down on the phone and then restart it, you've got to go in and stop the BluetoothPbapService all over again. The same if you do a reset or shut the phone down.
    08-10-2011 10:23 PM
  13. 04redgto's Avatar
    It definitely seems counter-intuitive but stopping the BluetoothPbapService has been the solution for me as well. I couldn't get the bluetooth module in my car to upload my phones contact list or keep the bluetooth connected until I stopped this "service". Just remember that if you shut the bluetooth connection down on the phone and then restart it, you've got to go in and stop the BluetoothPbapService all over again. The same if you do a reset or shut the phone down.
    This is correct. You can freeze the service. I use a app called bloat freezer to do this. That way you don't have to stop it when u turn Bluetooth off n on, or on reboots.
    08-11-2011 01:59 AM
LINK TO POST COPIED TO CLIPBOARD