1. shaneneff's Avatar
    I have purchased a Charge and received and activated the $25 credit. I got the Galaxy Tab and did the same thing, and then when i returned it after the moisture on the screen issue I received and activated a third one. The problem is that while my Media Hub sees these credits I can't use them- only the .10 left on the first card. Any ideas?

    Sent from my SCH-I510 using Tapatalk
    10-11-2011 09:54 PM
  2. papa54's Avatar
    I have purchased a Charge and received and activated the $25 credit. I got the Galaxy Tab and did the same thing, and then when i returned it after the moisture on the screen issue I received and activated a third one. The problem is that while my Media Hub sees these credits I can't use them- only the .10 left on the first card. Any ideas?

    Sent from my SCH-I510 using Tapatalk
    I'd guess you have used up yer credit..
    10-12-2011 12:17 AM
  3. jco23's Avatar
    you can only use them to buy/rent movies.
    10-12-2011 12:35 PM
  4. shaneneff's Avatar
    I only used $24 from the first card. The other cards show as available, but can't be selected as payment method. Oh, and yes I know they can only be used for video rentals and or purchases.

    Sent from my SCH-I510 using Tapatalk
    10-12-2011 07:59 PM
  5. jco23's Avatar
    interesting. did you try contacting Samsung about the issue? last time I called, I got someone right away.

    I do know that their promotion ended this summer, so perhaps that is the issue.
    10-13-2011 09:07 AM
LINK TO POST COPIED TO CLIPBOARD