1. EasyP's Avatar
    I was just wondering if my 4g speedtest result is low as it seems like everyone else is experiencing significantly higher speeds than I am...
    I guess what you need to know, Im in denver working downtown right now and my most recent result was
    3.4 down, 2.5 up. I dont get why my download is so close to my upload speed. Any tips welcome and its great that its better than the 600k that my coworkers get on 3G but i was thinking 6 down easy.
    Let me know
    06-22-2011 12:01 PM
  2. ellje's Avatar
    I was getting all worked up about this a week ago... I'd consistently received 15-17mb down, and suddently dropped to 8mb after EE4 (not sure they were related, but the timing was interesting).

    I since realized that if I change servers, I can go from 3mb down to 12mb down within 15 seconds... and everything in between. This kind of made the speed testing null and void, IMO.
    06-22-2011 01:35 PM
  3. EasyP's Avatar
    I was getting all worked up about this a week ago... I'd consistently received 15-17mb down, and suddently dropped to 8mb after EE4 (not sure they were related, but the timing was interesting).

    I since realized that if I change servers, I can go from 3mb down to 12mb down within 15 seconds... and everything in between. This kind of made the speed testing null and void, IMO.
    Yeah I noticed that my first test was in wichita kansas and I got 4.5 down... I guess ill just have to believe its faster... Honestly im still happy, but the X2 browsed the internet WAAYYYY faster in the verizon store.
    06-22-2011 02:50 PM
  4. skylinevspec's Avatar
    I just got my charge yesterday....and i have been running tests whenever I get into 4g....I have been between 11Mbps to a high of 22Mbps....this is in Pittsburgh Pa....so not really sure why your levels are low...guessing it just has to do with the network in your area
    06-22-2011 03:13 PM
  5. EasyP's Avatar
    Ok... So I have had the Charge for almost a month now and I still think there is an issue. Is there a possibility that my LTE receiver doesnt work as well? I saw someone else posting their 12M down speeds from Denver and yet I still cant even break 4 and I've tried from many different areas. Am I just being stupid and wanting to see my scores be higher or should I try to exchange it for another device?
    07-18-2011 06:04 PM
  6. davey11's Avatar
    Google speakeasy in your phone browser and they have a speed test which is done in the browser. I trust that more than the speedtest app. On my phone, the speed is double what I get with the app.

    Message sent from Tapatalk
    07-18-2011 07:00 PM
  7. dhp106's Avatar
    Google speakeasy in your phone browser and they have a speed test which is done in the browser. I trust that more than the speedtest app. On my phone, the speed is double what I get with the app.

    Message sent from Tapatalk


    Agreed, When i switched to Gingerbread i got around 8mps down on the speedtest app whereas i would get 15 with the speakeasy test.
    07-18-2011 07:03 PM
  8. fortesquieu's Avatar
    Agreed, When i switched to Gingerbread i got around 8mps down on the speedtest app whereas i would get 15 with the speakeasy test.
    The speedtest app isn't working well on Gingerbread.

    But, when i was on GB, I tethered the 4G to my computer to run the speed test, it was still way slower than the speed on EE4.
    07-19-2011 01:08 AM
  9. jono119's Avatar
    im on my second charge the first got around 20 average then i rooted and got no more than 3-4... the second one is stock not rooted and i average around 20-30 now. im all around the houston area.
    07-19-2011 09:41 AM
  10. ellje's Avatar
    The SpeedTest app is an absolute joke.

    I can get 18mb down off of one server, and 15 seconds later I can get 3mb down on a different server. If this doesn't invalidate any results, I don't know what does.

    I'll try to find this speakeasy app... I'm curious.
    07-19-2011 05:45 PM
  11. davey11's Avatar
    The speedtest app isn't working well on Gingerbread.

    But, when i was on GB, I tethered the 4G to my computer to run the speed test, it was still way slower than the speed on EE4.
    GB was okay and I could have lived with it...kinda sluggish but not bad. A few minor visual tweaks were nice.

    I HAD to go back to ee4 cos of the way slower lte speed, on both the speedtest app and speakeasy.
    Its not only on the speedtests, but in the way it downloaded files and webpages...way slower.
    07-19-2011 06:30 PM
  12. mcraig923's Avatar
    I've only had my charge for a little over a month, running stock but have always gotten between 19.8 - 24.5 down and between 3.45 - 5.85 up consistently.
    07-19-2011 09:21 PM
LINK TO POST COPIED TO CLIPBOARD