1. steelerfan791's Avatar
    Has anyone succeeded in getting HSPA+ speeds on the DNA? I live in Philadelphia and we were just moved to 1900 today. However, I was only able to get HSPA+ for like a minute and it keeps going back to edge :-( Does anyone know any tricks?
    12-20-2012 05:46 PM
  2. Ry's Avatar
    What settings are you using to connect to T-Mobile?
    12-20-2012 06:37 PM
  3. steelerfan791's Avatar
    I just popped the SIM in. I found if I put it in GSM/UMTS mode anf plut it on UMTS only it can;t switch to edge. However, it keeps losing signal. I'm thinking maybe because they just switched it over the network is a little unstable this evening. I'm hoping tomorrow it will be better.
    12-20-2012 06:56 PM
  4. Ry's Avatar
    I just popped the SIM in. I found if I put it in GSM/UMTS mode anf plut it on UMTS only it can;t switch to edge. However, it keeps losing signal. I'm thinking maybe because they just switched it over the network is a little unstable this evening. I'm hoping tomorrow it will be better.
    Have you changed any APN settings?
    12-20-2012 07:04 PM
  5. steelerfan791's Avatar
    Nope. It automatically set the APN to epc.tomobile.com From searching around this is the APN that I would enter.
    12-20-2012 07:13 PM
  6. steelerfan791's Avatar
    Grrrrrrrr. So the network seems more stable now. But, I can't get mms to work for the life of me. Whaaaaaaaaaa

    Sent from my HTC6435LVW using Android Central Forums
    12-20-2012 09:33 PM
  7. milan03's Avatar
    It's clearly not the phone, it's T-Mobile's not very dense UMTS1900Mhz 3G network. No tricks you could do besides "preferring WCDMA" or choosing "WCDMA ONLY" mode in Phone Info.
    12-22-2012 02:35 AM
  8. steelerfan791's Avatar
    Has anyone been able to get MMS to work on Tmo through the stock messaging app? I have googled my behind off and tried every APN setting I could find, nothing :-(
    12-22-2012 02:12 PM

Similar Threads

  1. tmobile g1 triangle with an exclamation point
    By millerd79 in forum T-Mobile G1
    Replies: 15
    Last Post: 12-29-2013, 01:14 PM
  2. 3G on 1900 MHz
    By Ry in forum T-Mobile
    Replies: 4
    Last Post: 01-02-2013, 11:05 AM
  3. T Mobile 1900 mhz
    By Younjulius in forum Samsung Galaxy Note 2
    Replies: 0
    Last Post: 11-09-2012, 07:43 PM
  4. I need to unlock my Tmobile G1... Help!!
    By saruth in forum The Android Central Lounge
    Replies: 2
    Last Post: 07-28-2009, 04:05 PM
  5. Tmobile g2
    By rjfabian in forum General News & Discussion
    Replies: 0
    Last Post: 06-30-2009, 03:46 PM
LINK TO POST COPIED TO CLIPBOARD