1. scubahiker's Avatar
    My wife's Inc was in a constant reboot loop. The only fix was to do a factory reset. Of course nothing was backed up on the phone so by doing a factory reset, we would loose everything. Thanks to everyone who responded to my initial post. I was successful in retrieving a good majority of all the files from the phone.

    I used PhotoRec and Recuva to recover the files. I found PhotoRec to be the better of the two as it got pics and videos - you name it!

    To start, I had to do the Factory reset - it was hard, but I did it. The phone rebooted and the Google setup started. Do not proceed forward - you do not want to write anything to the phones storage device. I shut the phone down, plugged the usb cable in and connected it to my computer. When I booted the phone back up I now had access to the phones USB control panel. I selected the needed option so I could access the storage device on the phone and ran the recovery s/w.

    PhotoRec did a great job at getting most everything and Recuva did as well. I just wanted to pass along how I recovered my files so if someone else is stuck, they don't have to loose their files.
    09-01-2011 10:24 AM
  2. PvilleComp's Avatar
    Thanks Scuba for sharing your solution! I'm sure others will benifit greatly.
    09-01-2011 07:02 PM
  3. dnafrequency's Avatar
    Someone brought in a Droid Incredible with this same exact issue. It's in a boot loop... gets to the red eyes then restarts. Will you share how you did the factory reset?

    Edit: The guides online are saying to first do the Clear Storage option. Since I have one shot at getting this right, I'd just like to hear what process you used.
    09-14-2011 07:49 PM
  4. dnafrequency's Avatar
    Went ahead with "Factory reset" option in the bootloader.

    At first I wasn't able to see the 8GB internal memory partition but after rebooting the phone and selecting the Mount As Drive USB option I was able to see the partition using "sudo photorec".

    I chose Intel/PC parition and then for filesystem type I chose "[Other]".

    All of the lost pictures, movies, and music started appearing in the destination directory!

    Update: Eventually got segmentation fault with PhotoRec 6.11 with Low Memory option turned either On or Off. This bug seems to have been fixed in version 6.12.
    ltacoleman likes this.
    09-15-2011 09:35 AM
  5. ltacoleman's Avatar
    Hi. I just joined so that I can tell you THANK YOU!

    My unrooted DInc started having that infernal bootloop crap earlier today. Everyone else was basically saying that you have to do a factory reset and will lose everything. I had already planned to reset sometime soon since I want to root my phone and get rid of that annoying low memory glitch crap (and maybe go up to Gingerbread finally), but I've been busy and haven't had a chance to back up my again since late December. I didn't want to lose any pics that were still stored in internal memory or my bookmarks, so I was trying to find a solution. Yours was the only one I could find and it has worked great!! I am almost done recovering my data.

    So thank you, thank you, thank you!!! *BIG hugs*


    EDIT: I called Verizon about this and they are sending me a replacement. Not sure what I'll be getting as it seems many are getting the DInc2 *fingers crossed* while others are getting the DInc. I'll post back after it arrives.
    Khushee likes this.
    01-19-2012 06:03 PM
  6. Khushee's Avatar
    I am stuck in the DeathLoop. I am a basic user, do not understand much about rooting. I do need to save my data. In addition to Pictures and Videos, the Voice recorder has so many .amr files, with first words and full sentences of my daughter. It would be a True Loss if I had to let go of them.

    Please Help! Where do I begin?
    01-19-2012 10:39 PM
  7. ltacoleman's Avatar
    Download PhotoRec (link is in the first post or you can Google it), then install it.
    Hold Volume Down while holding down the power button. This gets you into HBOOT. Select the Factory Reset option.
    As it says in the first post, the phone will boot into the setup you saw when you first got the phone. Power down the phone, connect it to pc via usb, then power on the phone. In the notification bar, it'll show the phone is charging. Change this to the Disk Drive option. Now you should be able to see the drive on your computer.
    Use PhotoRec and select the Android Drive. Follow the instructions for using PhotoRec and what others said in this thread.
    I was able to recover everything that was still stored on my internal memory since my last backup a couple weeks ago.
    Good luck!
    Khushee likes this.
    01-20-2012 02:22 AM
  8. Khushee's Avatar
    ScubaHiker; ItaColeMan;

    I am back, out of the DeathLoop, 4190+ files recovered. Learned a lesson - to back up!!!! Seriously!

    Thank you!
    01-21-2012 06:02 PM
  9. ltacoleman's Avatar
    That's great, Khushee! That is a lot of files! lol
    01-22-2012 06:38 PM
  10. helpfixmydroidincredible's Avatar
    I hope this solution still works 2+ years later because I am going to try it! Did anyone manage to recover contact information (phone numbers) from a boot looping phone? If so, please share how!
    10-27-2014 01:45 AM
  11. chandrasekharm's Avatar

    I'm using samsung S2 Hd Lte and it got stuck in a boot loop.I have many photos stored in the internal memory of the phone and i cannot afford to lose them. I saw your post that you recovered the photos from the internal memory using Photorec software. Can you give me the version of the software and the steps to follow for recovering the photos from my phone.

    11-19-2014 03:00 AM
  12. Jargonius's Avatar
    I tried this and it didn't work. If you have a newer version of Android (4.x and up I believe) then you can't connect to your phone using USB Mass Storage. Android uses Media Transfer Protocol now. So Recuva and PhotoRec don't work because they can't recognize the phone. There might be a program that does work via MTP but I couldn't find it. I did find this link which led me here. The Software Upgrade Assistant allowed me to restore my current version of Android without deleting my files but, sadly, I had already done the data wipe and factory reset. I tried dr.fone but I had to enable USB debugging to get that to work which meant setting up the phone and it didn't even find the pictures I wanted or allow pictures to be restored for free anyway. So, if you can find a solution like the Software Upgrade Assistant for your phone then I suggest you try it before doing the factory reset.
    12-29-2016 11:05 AM