1. rback15's Avatar
    Where i plug in the charger on the side of the phone i notice its way to loose.. It wiggles way to much it seems like it break wit one drop on that side.. Just wondering if anyone else has the same problem.. I thinking about calling verizon and requesting a new phone before something goes wrong.. Lol.
    05-08-2010 02:49 PM
  2. mc21's Avatar
    mine seems much more loose than my blackberry did, but it works so =\
    05-08-2010 03:07 PM
  3. dr.duct_mossburg's Avatar
    Mine is pretty firm.. Gotta really watch which way you put it in there.
    05-08-2010 03:36 PM
  4. teddeli's Avatar
    Where i plug in the charger on the side of the phone i notice its way to loose.. It wiggles way to much it seems like it break wit one drop on that side.. Just wondering if anyone else has the same problem.. I thinking about calling verizon and requesting a new phone before something goes wrong.. Lol.
    I don't think it's the port on the phone. It seems to be the way the cable fits. I tried it on my Blackberry Storm 2. The cable wiggles a bit but not the USP port on the phone.
    05-09-2010 08:26 AM
  5. imma_rage_quit's Avatar
    that's a rather personal question don't cha think? LOL

    seriously though. mine seems fine.
    05-09-2010 08:35 AM
  6. rpfarrah's Avatar
    Mine is pretty firm.
    05-09-2010 08:38 AM
  7. Mitch R.'s Avatar
    The connection is firm but the cable wiggled while it's plugged in. On my bb, I thought it was a loose connection only to find out that the connection is solid and it's the port inside the casing that's moving.
    05-09-2010 08:41 AM
LINK TO POST COPIED TO CLIPBOARD