1. JeffShultz's Avatar
    Okay, I've moved a bunch of apps over to the sd-card because the DINC app partition is too small (It's annoying to be told that I'm running low on application space when my monitoring app tells me I've got around 500mb left...).

    So, fine, now I can actually send and read text messages again.

    But when I try to update, every single one of those apps that are on the sd card toss up an error message of "Couldn't install on USB storage or SD card."

    Is this just something I've got to live with, having to copy apps back into phone storage prior to updating them?
    09-14-2011 01:06 PM
  2. adamm44's Avatar
    Did you move your apps to the sd card using settings or did you use an app to do it? If you used an app to do it, that might be the problem. It may not be compatible when trying to update the apps while on the sd card.
    09-14-2011 02:29 PM
  3. JeffShultz's Avatar
    I used the settings. Some of them I used App2SD to point me at the ones that could be changed, but it just took me to the Settings-->Applications--->particular app page to do it.
    09-14-2011 02:57 PM
  4. adamm44's Avatar
    This will take time depending on the amount of apps that won't update but, you can always try uninstalling then reinstalling the apps.
    09-14-2011 03:03 PM
  5. credo's Avatar
    I have the same issue. I moved all the apps back to phone to update. I don't have Gingerbread, yet.

    Sent from my ADR6300
    09-20-2011 01:46 PM
  6. miguelregu's Avatar
    Thanks for info on this thread. I have been frustrated for months on this issue and got it solved (at least a temp fix) by moving apps off SD card, updating and then moving bck to SD. Thanks!
    12-14-2011 02:46 PM
  7. kduffysr's Avatar
    I have had the exact same problem for months! Seems to be no fix. I have been moving apps back and forth to the SD card so they can update. So annoying! I have tried the remove the card and reboot thing. It doesnt work. The only thing left I can think of is to re-format the card. Reinstalling apps does not fix the problem either.
    09-08-2012 10:02 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD