1. pontoon78's Avatar
    I live in Brick Township, NJ. 90,000 people. I've had my Dinc since May and it has always had my town and accurate weather on it, and it always changed no matter where I went.

    Now it is stuck on Toms River and doesn't change anywhere. When I type in my town to add it, it tells me it doesn't exist. I re-booted and everything.

    Is there a way to re-set it or is there a similar widget out there like this? It's a small issue, but I really like the HTC weather widget, it is sort of their trademark.

    10-01-2010 08:52 AM
  2. m3rma1d's Avatar
    I'm having trouble with the weather widget in Toms River too.... I actually live up in Portland, Maine but my boyfriend lives down here in Toms River so I'm here a lot. Noticed since I've been here whenever it snows I only get a boring "cloudy" on my weather widget. It was like this for the entire Boxing Day blizzard (day after Xmas) so it really shoulda registered... and it's snowing now too, but still no cute little snowstorm on my homescreen. I wanna show off my cool phone!
    We're going to Brick in a little while (I'll wave to you) and up to Middletown later, and the snow is supposed to keep falling so I'll have to see if my phone "snows" in those towns...

    But anyways... not exactly the same issue as you, but another case of the weather widget going a bit wacky in Toms River haha
    01-07-2011 11:04 AM
  3. romy134's Avatar
    I had the exact same problem, it would always show the same location but all my other programs worked fine. Eventually I had to do a factory reset, but I only backed up my sms/mms and contacts I re downloaded all my apps. now it works like new.
    01-07-2011 01:36 PM
  4. sURFNmADNESS's Avatar
    I had this same problem with applications as my data/data directory was maxing out and getting a space warning.
    01-07-2011 09:20 PM
  5. Wanda's Avatar
    I've had similar problems from time to time. I got rid of the widget, then reselected it and put it back where it was...during the re-set up I just hit "use current location"...haven't had a problem since.
    01-08-2011 03:27 PM
  6. PvilleComp's Avatar
    I agree with Wanda. Remove the Widget and then replace the "Clock - HTC" widget, you have to side scroll to get to the Weather/Clock Widget. Mine has locked up once or twice (Weather Channel too) replaceing the Widget has always fixed the problem.

    Hope this helps.
    01-08-2011 03:35 PM
  7. Magick_Lady's Avatar
    And how do you remove it and place it back ? Tried everything else and its still not working for me
    11-22-2012 04:58 AM
  8. PvilleComp's Avatar

    If you long press on the clock widget the Remove Icon should appear. Drag the Widget to the remove icon. Then long press the space where it was and re-add the widget.

    Hope this helps.
    11-24-2012 06:43 PM