1. oatka's Avatar
    About a week ago I got my Incredible. within the first day or two (last thursday or friday) i installed the Grooveshark app. I tested it out, and I think that's when I decided to uninstall it. Well, currently for the last week it's been stuck. It shows up in the Market as "Installing" and no matter what I tried, it still shows "installing."

    I've tried to go to the Market to reinstall, but the installing message shows up.
    I've tried to go to the grooveshark website, but it redirects to the market and the installing message shows up.
    I've tried removing the grooveshark folder I found when I connected the phone to the PC.

    any ideas how to get it to stop this?

    I have a feeling that might be part of the reason my battery doesn't work for as long as I think it should (I have read up on the battery info, so I know there's steps to take to get it to perform better, but I still want this app to figure itself out so I can reinstall it.)

    10-30-2010 03:08 PM
  2. Vudumedic's Avatar
    can you install other apps say something like angry birds or does that stall as well? If it does stall then it is probably an issue with the android secure file on your SD card and that can be fixed easily enough. Following the steps laid out in this thread.

    How to fix stuck app downloads [From the Forums] | Android Central

    If you don't want to download astrid to do the deleting then just connect your phone to your computer access the disk drive for your SD card find the . android folder and delete it that way.
    10-30-2010 03:18 PM
  3. oatka's Avatar
    Thanks! That fixed it!
    10-30-2010 06:27 PM
  4. skidoog22's Avatar
    I'm having the same issue with an application installation never ending. The difference is, it's installing directly to the phone. Just for grins, I did delete the secure file on my SD card. Of course that didn't fix it. Any ideas how to crash this install?
    11-04-2010 04:31 PM
  5. mclarryjr's Avatar
    Try unmounting your sdcard then try to install that is what I have to do. To unmount just hit menu.settings.phone storage &SD.then select unmount.
    11-04-2010 04:58 PM
  6. rog152's Avatar
    Lol, I had the same problem with the app ZGames and you know how i got rid of it. I walked into a Verizon store,-- and when I went to show the rep the problem it was all fixed, no kidding lol.
    11-04-2010 06:00 PM
  7. greydarrah's Avatar
    An easy fox for this problem is to go into manage applications, click the All tab, select Market, then hit clear data. You wont lose anything, it just requires you to agree to the market terms the next time you launch it.
    11-04-2010 06:34 PM
  8. dyastrab's Avatar
    Try uninstalling Android Market in Manage Applications. This doesn't actually uninstall Market but it will stop the installation screen that you're seeing.
    11-05-2010 10:02 AM
  9. skidoog22's Avatar
    Thank you greydarrah!

    I did what you suggested and it worked exectly as you described.

    It's nice not to see that anymore, who knows if it was actually doing anything and draining my battery....
    11-05-2010 11:23 AM