1. agahran's Avatar
    I've been having a sporadic, weird problem with my Droid Incredible. I *think* I may have found a solution, albeit an annoying one. But I figured I'd post it here in case it's either helpful, or if someone can suggest a better solution.

    THE PROBLEM: My Droid Incredible will sometimes stop ringing when I get an incoming call. The ringer is on and loud, that's not the problem. And calls are coming in, because if I happen to be looking at the screen when a call comes I can see it visually. But: no audible ring.

    Furthermore, my Dinc stopped displaying a visual "missed call" alert on the home screen. The only way I'd know I'd missed a call would be to go into the phone app and check the call history.

    This is a big problem for me, since I live in a gated apt. complex and the only way I know someone is at the gate for me is when they call me. (Gate box rings through to my phone, no intercom in my apt.) I've missed package deliveries and friends stopping by because of this.

    Coincidentally, at the same time this problem started cropping up (it comes and goes), I noticed that verizon location services alone would no longer suffice to find my location on maps or in location-based services like 4square or Facebook places. I'd have to turn on Google location support or GPS to get them to work. That didn't used to be the case. This may or may not be related to the ringing problem.

    THE SOLUTION (SO FAR): I called Verizon, and was told that I needed to update my roaming -- and furthermore, that all Dinc users should do this every 2-3 months. (News to me.)

    Here's the process Verizon had me do:

    1. Power down Dinc, remove battery, leave out for a minute or so. Then put battery back in and power up.

    2. Call *228 and choose option 2 to update roaming. Then hit any key or OK. (According to Vzw, part of what this does is update your phone's location with local towers).
    - This caused my phone to display a message that it was updating roaming. Then my phone restarted itself again.

    3. Per Vzw instructions, I then called *73 -- which is apparently how you deactivate call forwarding. (I don't know why they had me do this, but it seemed to do no harm. I did not have call forwarding activated.)

    Since I did that yesterday, my phone has been ringing for incoming calls.

    BUT: I still had the problem of no missed call indicator on the home screen.

    On that front, I've noticed that my phone never seems to go into sleep mode anymore. So when I activate the phone, it's always fully ready to go -- no bar sitting halfway up the screen showing the time that I have to drag down to start using the phone -- and no notifications (like for a missed call) under that bar. Once I drag down the bar, the phone is always live until I power it off.

    I don't know how to fix that problem, would appreciate suggestions on that.

    Thoughts on any of this?

    When I turned off the security lock, I started seeing a home screen missed call notification.
    12-17-2010 02:56 PM
  2. jayhawkfan18's Avatar
    When I turned off the security lock, I started seeing a home screen missed call notification.
    What do you mean by this? Did you install an app like NoLock that disables your lock screen?

    If your phone never sleeps then that could be a problem. I bet your battery life is even worse than normal if that's the case. Most likely it is an app that is causing this. I would go into settings>applications>running services and post what shows up there for starters.

    Are you getting any notification in the notification bar when you miss a call?
    12-17-2010 05:23 PM
  3. agahran's Avatar
    Thanks, JayHawkFan18

    After investigating further, I think the problem is not the security lock (and I did not install an app, just used the feature under the Android "security" setting). Rather, it appears that my phone will not go into standby mode. And now that I think back, I've been having that particular problem for a few weeks.

    This may be separate from the sporadic not-ringing problem, but it's related, because when I activate the phone to see the standby mode screen, that's where an obvious missed call notification would appear.

    And yes, I'm sure not going into standby mode is bad for my battery life. My phone has lousy battery life.

    I've been scouring forums and info from HTC, but I haven't found any info for how to get a Dinc to resume going into standby mode. There doesn't appear to be a setting for it.

    I do get a notification in the notification bar when I miss a call, but it's very tiny and easy to miss, and can get pushed back by other notifications. I'd like to find a way to limit what kinds of notifications get shown as icons in that bar, right now it's too much.

    I regularly shut down unneeded running services and apps. I used to use a task killer, but that got flaky so I just do it manually when I need to conserve battery power.

    But this no-standby issue is a problem. Advice welcome. Thanks.
    12-17-2010 06:00 PM
  4. jayhawkfan18's Avatar
    So when you go into running services what is listed there? Can you list all of the apps that you have installed? My guess is there is an app that you have that is constantly running and not letting the phone enter standby mode...
    12-17-2010 06:11 PM
  5. agahran's Avatar
    Anytime I go into running services I see several running services for apps like Paypal and Skype -- I kill them if I'm not using them, but I've been seeing that happen since I got my phone and this lack of standby mode is only a few weeks old.

    I installed the Spare Parts app, which lets you view which apps are doing "partial wake usage". There, the chat client ebuddy was a clear culprit. I've uninstalled ebuddy and replaces it with Meebo, which doesn't seem to partially wake the phone, and which is easier to quit completely.

    But I've pulled the battery a couple of times since then, and still no standby mode.
    12-18-2010 12:23 PM
  6. agahran's Avatar
    HTC is not really any help. They just recommend that I pull the battery, then "uninstall any 3rd party apps" (like that's not gonna be an even bigger inconvenience to me, to then reinstall apps) and then finally do a factory reset, wiping out all my painstaking constructed preferences.

    This is not an acceptable response, as far as I'm concerned. Standby mode is a basic feature of the phone. There should be a setting for it, where I can either force-resume it, or get an answer as to why it won't go into standby mode.

    In the meantime, I'm testing another app called "missed Reminder" to see if it will solve my missing notifications of missed calls problem

    Missed Reminder ~ Android Application v0.9.6 By Denis Solonenko | Tools

    UPDATE: The "missed reminder" app does not seem to be working for me. I don't get the visual or audible notifications of missed calls that I'm requesting in the preferences for that app. This is really annoying, it's a basic functionality of the phone to got into standby mode and clearly and immediately notify me of missed calls.

    Wish me luck.
    12-18-2010 01:44 PM
  7. agahran's Avatar
    OK, uninstalled a bunch of apps that I don't use as much, and now I have standby mode and missed call notification back. So one of them was the culprit. Fortunately did NOT have to uninstall all apps.

    ok, so problem solved. I don't know which app was the culprit, I killed about 8.
    12-18-2010 02:46 PM
  8. jayhawkfan18's Avatar
    Maybe list the apps you uninstalled and someone may be able to help you narrow down which one it was...

    Glad you got it working again.

    Sent from my ADR6300 using Tapatalk
    12-18-2010 06:29 PM
  9. KB3MMX's Avatar
    dialing *22899 is easier, no need to use option 2, its automatic.
    12-18-2010 09:02 PM
LINK TO POST COPIED TO CLIPBOARD