08-09-2011 08:35 PM
27 12
tools
  1. Funkpod's Avatar
    Whenever I hold down the search button and say "Call ____________" and it's a business that i do not have in my phone, it adds "+1" before the area code. I have a droid incredible, btw. on verizon (obviously, hehe).

    i'll say "call mcdonald's" and it'll dial "+1610xxxxxxx"

    However, because it adds this "+1", it cannot dial, and a verizon voice comes on and says something like,

    "welcome to Verizon wireless. your call cannot be completed as dialed. please check the number and dial again. announcement 4 switch 8-4"

    this is a pretty big problem, cuz i have to memorize the number and retype it and then dial it. which is like, the opposite of what i should be doing. and it's kind of hard to show off the cool Voice Search feature on your phone if you can't dial all the time...


    also, htc told me that their handsets there have the problem... but it seems like my friends w/ droid X don't when speaking the same commands...

    any suggestions?
    03-01-2011 05:57 AM
  2. Funkpod's Avatar
    hey, do me a favor, when you hold down the magnifying glass, the search button, and say "Call McDonalds", what happens?

    get the "+1"?
    03-01-2011 08:24 AM
  3. Funkpod's Avatar
    Hello, I just noticed something ...

    in Google Voice, my voicemail service, I notice that any number that is NOT a contact is displayed w/ a "+1" in front of it. Could this be related to Google Voice?

    i don't have a Google Voice number, though.
    03-01-2011 02:49 PM
  4. CRKhead's Avatar
    I just noticed a bunch of my contacts now have a "+1" in front of their numbers...
    03-05-2011 11:05 AM
  5. Funkpod's Avatar
    hmm... what happens when you say "Call McDonalds" ?

    you're not rooted, right?
    03-06-2011 07:58 PM
  6. Jude526's Avatar
    I am not seeing a 1 when I am dialing or a call coming in. But I did on my BB because that's how RIM wanted it
    03-07-2011 11:44 PM
  7. Funkpod's Avatar
    The problem isn't the " 1" , it's the " +1" .verizon won't let complete a call. It's so frustrating cuz just the other day, I said " call home depot" , but it didn't work. There was " +" in front of the number. So I had to memorize the number and then manually dial it.
    03-08-2011 02:13 AM
  8. CRKhead's Avatar
    The "+1" shows up in my Voice Dials, like when I tested by calling McDonalds, and the call goes through fine... A lot of my contacts now have the +1 though... It's odd...

    Searching through this and other forums for "+1" isn't very helpful either... Damn forum short-speak...
    03-08-2011 07:25 AM
  9. PvilleComp's Avatar
    Searching through this and other forums for "+1" isn't very helpful either... Damn forum short-speak...
    +1






    Sorry - could not resist.
    Funkpod likes this.
    03-08-2011 08:20 AM
  10. Funkpod's Avatar
    hehe, good one!

    yeah, it's too tough to search, and honestly, i can't seem to find anyone else having the problem except 1 other person on a google forum... but haven't been able to connect w/ that person.

    here are my questions:

    1. will a factory reset help? i would HATE to do this, resetting everything up, etc. BUT, this is a pretty big feature to be missing, so I would do it if needed.
    2. OR, is this a HTC problem, like, I need to talk w/ enough people who have STOCK never been rooted HTC Sense... to see if this is a Sense problem or just a ME problem.

    okay...
    03-08-2011 03:09 PM
  11. mikestorm's Avatar
    Bumping this as the very same thing is happening to me. Anyone else and is there a fix?
    05-29-2011 09:20 PM
  12. Funkpod's Avatar
    No fix yet...not that I know of, unfortunately. Same symptoms? I think it has something to do with stock sense, as rooted users don't seem to have this problem...
    05-30-2011 06:29 AM
  13. mikestorm's Avatar
    I'm rooted with das bamf. Also I have a thunderbolt.
    here are my symptoms:
    google voice search adds a plus at the beginning of any number I try and call (e.g. "call Wal-mart" returns +12125551212, instead of 12125551212. triggers a verizon wireless message that says call cannot be completed as dialed.

    google voice adds a plus to any number not my contacts . same verizon message when I attempt to dial right from Google voice.

    since the symptoms technically span two different apps (google voice and google voice search) and two different phones that suggests it a sense issue or setting. I suspect there's a setting that doesn't overtly specify our phones are tied to the USA.

    My fiance has an incredible that isn't affected. I'll compare settings on each phone and let you know.
    05-30-2011 06:46 AM
  14. mikestorm's Avatar
    Made a bit of progress.

    Google Voice Search on my GFs Incredible shows +1 (800)-555-1212 in the Google App, but when the number is sent to the dialer for fulfillment, the dialer shows [HL]18005551212.[/HL]

    Google Voice Search on my Thunderbolt shows hows +1 (800)-555-1212 in the Google App, but when the number is sent to the dialer for fulfillment, the dialer shows [HL]+18005551212.[/HL]

    This suggests the issue may be how the HTC dialer app is configured. I'm going to find and reinstall the dialer apk to see if that fixes the problem.
    05-30-2011 12:42 PM
  15. Funkpod's Avatar
    thanks for trying to diagnose the problem!

    i wonder why your girlfriend's phone doesn't have this problem...

    let me know what happens when you reinstall the dialer apk. would i be able to do that if not rooted?

    verizon and htc's help was simply to hard reset "Use Vlingo."
    i couldn't believe it!

    well, i am using vlingo it's really nice, never doubted that it was nice, i just wanted to use Google's voice search app.

    oh well.

    let us know what happens!
    05-31-2011 07:49 AM
  16. mikestorm's Avatar
    thanks for trying to diagnose the problem!

    i wonder why your girlfriend's phone doesn't have this problem...

    let me know what happens when you reinstall the dialer apk. would i be able to do that if not rooted?

    verizon and htc's help was simply to hard reset "Use Vlingo."
    i couldn't believe it!

    well, i am using vlingo it's really nice, never doubted that it was nice, i just wanted to use Google's voice search app.

    oh well.

    let us know what happens!
    Different ROM I would imagine. I have virtuous 3.2 installed on her phone. As for me, no dice on the phone app reinstall. Upgraded from 1.6.3 nte to 1.7 and problem persists.
    05-31-2011 03:53 PM
  17. Funkpod's Avatar
    See, I agree with you that it probably is Sense. But, what to do...
    05-31-2011 04:17 PM
  18. mikestorm's Avatar
    Wait for gingerbread I imagine. Odd that more people aren't affected.
    05-31-2011 07:24 PM
  19. PvilleComp's Avatar
    Per the HTC Manual...

    Using Assisted Dialing
    Assisted Dialing allows you to easily dial international calls while roaming in another country.
    Turning Assisted Dialing on
    1. Press HOME > MENU, and then tap Settings > Call > Assisted Dialing.
    2. Select the Enable Assisted Dialing check box.
    3. Under Reference Country, select the country that you want to call.

    Editing a country’s international call settings
    1. Press HOME > MENU, and then tap Settings > Call > Assisted Dialing.
    2. Under Reference Country, select the country whose settings you want to edit.
    3. Press MENU and then tap Edit.
    4. Edit the Country Code, IDD Prefix (International Direct Dial), NDD Prefix (National Direct Dial), Area/City Code and National Number Length (length of phone number).
    5. Tap Save.

    To reset the Reference Country to the default
    1. Press HOME > MENU, and then tap Settings > Call > Assisted Dialing.
    2. Under Reference Country, select the country whose settings you want to set to default values.
    3. Press MENU and then tap Set Default.
    If you can't disable the Assisted Dialing try editing the US entry from 011 to just 1.

    Hope this helps.
    05-31-2011 08:33 PM
  20. mikestorm's Avatar
    Thanks PvilleComp, but neither disabling assisted dialing nor editing the international code from 011 to 1 helped. Still dials with plus prefix.
    06-02-2011 08:44 PM
  21. PvilleComp's Avatar
    I remember a long time ago Facebook was adding the +1 to phone numbers when syncing contacts with Facebook. So I guess I'll ask... Are you syncing contacts with Facebook?

    If I remember correctly, once it was done it had to be edited out of every contact, but not syncing Facebook contacts kept it from returning.

    Worth a shot.
    06-02-2011 09:14 PM
  22. mikestorm's Avatar
    it's actually not my contacts. it's google voice dialing voice actions. "call pepboys " used to work on my incredible but my thunderbolt adds a plus to the number and the call doesn't go through.

    I'm beginning to think assisted dialing doesn't actually work at all in this rom. I've tried various countries and nothing seems to change.
    06-02-2011 10:03 PM
  23. Funkpod's Avatar
    It's interesting that you "used " to be able to do the dialing with your Incredible. I seem to remember that I used to as well, however, i definitely can't anymore. I wonder if it was the froyo upgrade...
    06-03-2011 05:16 AM
  24. mikestorm's Avatar
    Still can with the DInc. I gave it to my fiance, which is why I now say 'used to' since its technically hers now
    06-03-2011 06:52 PM
  25. ckeran's Avatar
    A little bit different problem with +1...

    I have a Tbolt and one of my contacts has this +1 included and prevents me from dialing. Not sure where this +1 came from--I think after the recent upgrade (late July 2011). I even deleted this contact and created a new one and it added a +1 again. Ok, so maybe it adds a +1 to all new contacts? Nope, tried adding a different one and it didn't add the +1. Bizarre.

    Any thoughts?
    08-08-2011 03:15 PM
27 12
LINK TO POST COPIED TO CLIPBOARD