1. jack22182's Avatar
    Has anyone successfully applied the current Swype Beta to DL30? I re-sent my beta installer link and did the following:

    • Went to Settings>Applications>Manage Applications to uninstall the current Swype per the instructions, but the Uninstall button remained dimmed (even tried to force stop)
    • Uninstalled it using TBU instead
    • Ran the beta installer, received "Installation Failed" error message

    Has anyone else had any luck with this? I got really spoiled by the Beta while I was running the DL09 Superclean. Could this just be the dreaded "If your phone came pre-installed with Swype DO NOT download this beta (it won't work)" issue now that I'm running DL30?
    02-02-2011 11:02 PM
  2. jbm1981's Avatar
    I found these instructions posted over at xda. They worked for me. Hope this helps

    I used the beta installer (will allow updates this way) rather than the actual apk and it works flawlessly.

    1. Install the beta installer (from swype's website)
    2. Change to Android keyboard
    3. Use Root Explorer to go to /system/app
    4. Delete Skype apk
    5. Go to /system/lib and delete libswypecore.so
    6. Reboot
    7. Open Swype installer and it should now allow you to install the newest version.

    jack22182 likes this.
    02-02-2011 11:16 PM
  3. Chris Kerrigan's Avatar
    Someone in one of the other threads was sent into a FC Loop of Hell when they manually removed the Swype apk and corresponding odex file. So, you might be right in your last statement there. It's probably one of those situations where even though it doesn't really need to be, it's so baked into the OS that changing it in any way screws the system up.

    EDIT: LOL! Thanks for updating us! Glad that worked for you.
    jack22182 likes this.
    02-02-2011 11:17 PM
  4. dmt619's Avatar
    I used Titanium backup to remove swype then deleted any leftover swype files with root explorer rebooted, and installed swype beta with no issues.
    jack22182 likes this.
    02-02-2011 11:23 PM
  5. vespaholic's Avatar
    for those cheep skates out there like me, super manager which is a free alternative to Root Explorer. It worked for me.

    super manager:
    jack22182 likes this.
    02-03-2011 01:40 AM
  6. jack22182's Avatar
    Exactly what I was looking for - thanks folks! It works great!
    02-03-2011 09:29 AM